summaryrefslogtreecommitdiff
path: root/python-docraptor.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 00:01:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 00:01:32 +0000
commitc34f764b2c285ab3193818ba876032be50e24b29 (patch)
tree0725f9df9d483e953b61613b5e03e8516b766b72 /python-docraptor.spec
parent9c3e520e25c870b6a4c7eb625bd8f6e6de7f39d1 (diff)
automatic import of python-docraptor
Diffstat (limited to 'python-docraptor.spec')
-rw-r--r--python-docraptor.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-docraptor.spec b/python-docraptor.spec
new file mode 100644
index 0000000..2d9e88c
--- /dev/null
+++ b/python-docraptor.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-docraptor
+Version: 3.0.0
+Release: 1
+Summary: DocRaptor
+License: MIT
+URL: https://pypi.org/project/docraptor/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3e/8d/a77e269e30361bc23951b5b21606ea4c1eb3e16c06cb54c00144ea339502/docraptor-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-urllib3
+Requires: python3-six
+Requires: python3-dateutil
+
+%description
+ A native client library for the DocRaptor HTML to PDF/XLS service. # noqa: E501
+
+
+
+%package -n python3-docraptor
+Summary: DocRaptor
+Provides: python-docraptor
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-docraptor
+ A native client library for the DocRaptor HTML to PDF/XLS service. # noqa: E501
+
+
+
+%package help
+Summary: Development documents and examples for docraptor
+Provides: python3-docraptor-doc
+%description help
+ A native client library for the DocRaptor HTML to PDF/XLS service. # noqa: E501
+
+
+
+%prep
+%autosetup -n docraptor-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-docraptor -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated