summaryrefslogtreecommitdiff
path: root/python-docutils-stubs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-docutils-stubs.spec')
-rw-r--r--python-docutils-stubs.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-docutils-stubs.spec b/python-docutils-stubs.spec
new file mode 100644
index 0000000..c1c5f89
--- /dev/null
+++ b/python-docutils-stubs.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-docutils-stubs
+Version: 0.0.22
+Release: 1
+Summary: PEP 561 type stubs for docutils
+License: Unlicense
+URL: https://github.com/tk0miya/docutils-stubs
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/31/fb/3eda037eed8b98d6b2169e4198a8f12a03a461c4d4dc44de1a7790d0f7c7/docutils-stubs-0.0.22.tar.gz
+BuildArch: noarch
+
+Requires: python3-docutils
+
+%description
+`PEP 561`_ based Type information for docutils_.
+
+%package -n python3-docutils-stubs
+Summary: PEP 561 type stubs for docutils
+Provides: python-docutils-stubs
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-docutils-stubs
+`PEP 561`_ based Type information for docutils_.
+
+%package help
+Summary: Development documents and examples for docutils-stubs
+Provides: python3-docutils-stubs-doc
+%description help
+`PEP 561`_ based Type information for docutils_.
+
+%prep
+%autosetup -n docutils-stubs-0.0.22
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-docutils-stubs -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.22-1
+- Package Spec generated