summaryrefslogtreecommitdiff
path: root/python-dput.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dput.spec')
-rw-r--r--python-dput.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-dput.spec b/python-dput.spec
new file mode 100644
index 0000000..be01d8e
--- /dev/null
+++ b/python-dput.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dput
+Version: 1.6
+Release: 1
+Summary: dput-ng -- like dput, but better
+License: GPL-2+
+URL: UNKNOWN
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/29/da/996f4012af8bdcefae19474649ef0f1918ebb7816816031e29000718e873/dput-1.6.tar.gz
+BuildArch: noarch
+
+
+%description
+dput-ng is a from-scratch refresh of the old `dput(1)` command. This tool is
+used (at some point) to aid with the act of uploading a package to an archive.
+dput-ng aims to be compatible with the old `dput(1)` config files, while
+adding additional features for better sanity checking, and designed in an
+extensible way.
+Check the [docs](http://dput.rtfd.org) for more on topics that might
+interest you.
+
+%package -n python3-dput
+Summary: dput-ng -- like dput, but better
+Provides: python-dput
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dput
+dput-ng is a from-scratch refresh of the old `dput(1)` command. This tool is
+used (at some point) to aid with the act of uploading a package to an archive.
+dput-ng aims to be compatible with the old `dput(1)` config files, while
+adding additional features for better sanity checking, and designed in an
+extensible way.
+Check the [docs](http://dput.rtfd.org) for more on topics that might
+interest you.
+
+%package help
+Summary: Development documents and examples for dput
+Provides: python3-dput-doc
+%description help
+dput-ng is a from-scratch refresh of the old `dput(1)` command. This tool is
+used (at some point) to aid with the act of uploading a package to an archive.
+dput-ng aims to be compatible with the old `dput(1)` config files, while
+adding additional features for better sanity checking, and designed in an
+extensible way.
+Check the [docs](http://dput.rtfd.org) for more on topics that might
+interest you.
+
+%prep
+%autosetup -n dput-1.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dput -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6-1
+- Package Spec generated