summaryrefslogtreecommitdiff
path: root/python-edx-search.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 05:36:38 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 05:36:38 +0000
commit3526c5ec06e79d3fd1726b3c49ad59e1e68985e4 (patch)
treeb1936e02f560d0b10e7245a2999e18b67cba338a /python-edx-search.spec
parentc5c2b0574e99213ef996ec314a5ece2b8bd8ab54 (diff)
automatic import of python-edx-search
Diffstat (limited to 'python-edx-search.spec')
-rw-r--r--python-edx-search.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-edx-search.spec b/python-edx-search.spec
new file mode 100644
index 0000000..c0394ec
--- /dev/null
+++ b/python-edx-search.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-edx-search
+Version: 3.5.0
+Release: 1
+Summary: Search and index routines for index access
+License: AGPL
+URL: https://github.com/openedx/edx-search
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/45/95ebfb2c7f83b0a5e63257c1e0fae94f4cb9bcbfe789b04d334a47971b63/edx-search-3.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-event-tracking
+Requires: python3-edx-toggles
+Requires: python3-elasticsearch
+Requires: python3-Django
+
+%description
+
+
+%package -n python3-edx-search
+Summary: Search and index routines for index access
+Provides: python-edx-search
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-edx-search
+
+
+%package help
+Summary: Development documents and examples for edx-search
+Provides: python3-edx-search-doc
+%description help
+
+
+%prep
+%autosetup -n edx-search-3.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-edx-search -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.5.0-1
+- Package Spec generated