summaryrefslogtreecommitdiff
path: root/python-emoji.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-emoji.spec')
-rw-r--r--python-emoji.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-emoji.spec b/python-emoji.spec
new file mode 100644
index 0000000..5a2eda6
--- /dev/null
+++ b/python-emoji.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-emoji
+Version: 2.2.0
+Release: 1
+Summary: Emoji for Python
+License: New BSD
+URL: https://github.com/carpedm20/emoji/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/3c/26aefc6bbfa015e1dabbabd6881103e236c7ae67fabb3265fef0c85e89b5/emoji-2.2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Emoji for Python. This project was inspired by `kyokomi <https://github.com/kyokomi/emoji>`__.
+
+%package -n python3-emoji
+Summary: Emoji for Python
+Provides: python-emoji
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-emoji
+Emoji for Python. This project was inspired by `kyokomi <https://github.com/kyokomi/emoji>`__.
+
+%package help
+Summary: Development documents and examples for emoji
+Provides: python3-emoji-doc
+%description help
+Emoji for Python. This project was inspired by `kyokomi <https://github.com/kyokomi/emoji>`__.
+
+%prep
+%autosetup -n emoji-2.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-emoji -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.0-1
+- Package Spec generated