summaryrefslogtreecommitdiff
path: root/python-enhanced-dpy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-enhanced-dpy.spec')
-rw-r--r--python-enhanced-dpy.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-enhanced-dpy.spec b/python-enhanced-dpy.spec
new file mode 100644
index 0000000..a17b8e1
--- /dev/null
+++ b/python-enhanced-dpy.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-enhanced-dpy
+Version: 1.7.3.7.post6
+Release: 1
+Summary: A Python wrapper for the Discord API
+License: MIT
+URL: https://github.com/iDutchy/discord.py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/53/1e/738fb4c8651d82812594a9d057902801b1cef39b6581e64967002318234c/enhanced-dpy-1.7.3.7.post6.tar.gz
+BuildArch: noarch
+
+
+%description
+A modern, easy to use, feature-rich, and async ready API wrapper for Discord written in Python.
+Credits to the `original lib by Rapptz <https://github.com/iDutchy/discord.py>`_
+**WARNING: This is not the official discord.py lib! This is a custom version to which I add some features that might be useful or just makes things easier for the lazy people. See below which features have been added. This lib will also be kept updated with the BETA version of the original lib! So things may be unstable, please keep that in mind.**
+
+%package -n python3-enhanced-dpy
+Summary: A Python wrapper for the Discord API
+Provides: python-enhanced-dpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-enhanced-dpy
+A modern, easy to use, feature-rich, and async ready API wrapper for Discord written in Python.
+Credits to the `original lib by Rapptz <https://github.com/iDutchy/discord.py>`_
+**WARNING: This is not the official discord.py lib! This is a custom version to which I add some features that might be useful or just makes things easier for the lazy people. See below which features have been added. This lib will also be kept updated with the BETA version of the original lib! So things may be unstable, please keep that in mind.**
+
+%package help
+Summary: Development documents and examples for enhanced-dpy
+Provides: python3-enhanced-dpy-doc
+%description help
+A modern, easy to use, feature-rich, and async ready API wrapper for Discord written in Python.
+Credits to the `original lib by Rapptz <https://github.com/iDutchy/discord.py>`_
+**WARNING: This is not the official discord.py lib! This is a custom version to which I add some features that might be useful or just makes things easier for the lazy people. See below which features have been added. This lib will also be kept updated with the BETA version of the original lib! So things may be unstable, please keep that in mind.**
+
+%prep
+%autosetup -n enhanced-dpy-1.7.3.7.post6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-enhanced-dpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.3.7.post6-1
+- Package Spec generated