summaryrefslogtreecommitdiff
path: root/python-ensure.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 04:41:11 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 04:41:11 +0000
commit72ea080a1d55a57139e703103615fb1ae437f03b (patch)
tree26472990284f6e85f956c3e56d494dd016f7173f /python-ensure.spec
parentf4b30f0a6ce4dc60e52c05830286f8ce6d581488 (diff)
automatic import of python-ensure
Diffstat (limited to 'python-ensure.spec')
-rw-r--r--python-ensure.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/python-ensure.spec b/python-ensure.spec
new file mode 100644
index 0000000..903f485
--- /dev/null
+++ b/python-ensure.spec
@@ -0,0 +1,111 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ensure
+Version: 1.0.2
+Release: 1
+Summary: Literate BDD assertions in Python with no magic
+License: Apache Software License
+URL: https://github.com/kislyuk/ensure
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/21/99/ba5d6a41579e0cf174e521543f1a944f338e581d66163ba45dbcc7bfe2e1/ensure-1.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-coverage
+Requires: python3-flake8
+
+%description
+*ensure* is a set of simple assertion helpers that let you write more expressive, literate, concise, and readable
+Pythonic code for validating conditions. It's inspired by `should.js <https://github.com/shouldjs/should.js>`_,
+`expect.js <https://github.com/Automattic/expect.js>`_, and builds on top of the
+`unittest/JUnit assert helpers <http://docs.python.org/2/library/unittest.html#assert-methods>`_.
+If you use Python 3, you can use *ensure* to enforce your **function signature annotations**: see
+`PEP 3107 <http://www.python.org/dev/peps/pep-3107/>`_ and the
+@ensure_annotations decorator below.
+Because *ensure* is fast, is a standalone library (not part of a test framework), doesn't monkey-patch anything or use DSLs,
+and doesn't use the assert statement (which is liable to be turned off with the ``-O`` flag), it can be used to validate
+conditions in production code, not just for testing (though it certainly works as a BDD test utility library).
+Aside from better looking code, a big reason to use *ensure* is that it provides more consistent, readable, and
+informative error messages when things go wrong. See
+`Motivation and Goals <https://github.com/kislyuk/ensure#motivation-and-goals>`_ for more.
+
+%package -n python3-ensure
+Summary: Literate BDD assertions in Python with no magic
+Provides: python-ensure
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ensure
+*ensure* is a set of simple assertion helpers that let you write more expressive, literate, concise, and readable
+Pythonic code for validating conditions. It's inspired by `should.js <https://github.com/shouldjs/should.js>`_,
+`expect.js <https://github.com/Automattic/expect.js>`_, and builds on top of the
+`unittest/JUnit assert helpers <http://docs.python.org/2/library/unittest.html#assert-methods>`_.
+If you use Python 3, you can use *ensure* to enforce your **function signature annotations**: see
+`PEP 3107 <http://www.python.org/dev/peps/pep-3107/>`_ and the
+@ensure_annotations decorator below.
+Because *ensure* is fast, is a standalone library (not part of a test framework), doesn't monkey-patch anything or use DSLs,
+and doesn't use the assert statement (which is liable to be turned off with the ``-O`` flag), it can be used to validate
+conditions in production code, not just for testing (though it certainly works as a BDD test utility library).
+Aside from better looking code, a big reason to use *ensure* is that it provides more consistent, readable, and
+informative error messages when things go wrong. See
+`Motivation and Goals <https://github.com/kislyuk/ensure#motivation-and-goals>`_ for more.
+
+%package help
+Summary: Development documents and examples for ensure
+Provides: python3-ensure-doc
+%description help
+*ensure* is a set of simple assertion helpers that let you write more expressive, literate, concise, and readable
+Pythonic code for validating conditions. It's inspired by `should.js <https://github.com/shouldjs/should.js>`_,
+`expect.js <https://github.com/Automattic/expect.js>`_, and builds on top of the
+`unittest/JUnit assert helpers <http://docs.python.org/2/library/unittest.html#assert-methods>`_.
+If you use Python 3, you can use *ensure* to enforce your **function signature annotations**: see
+`PEP 3107 <http://www.python.org/dev/peps/pep-3107/>`_ and the
+@ensure_annotations decorator below.
+Because *ensure* is fast, is a standalone library (not part of a test framework), doesn't monkey-patch anything or use DSLs,
+and doesn't use the assert statement (which is liable to be turned off with the ``-O`` flag), it can be used to validate
+conditions in production code, not just for testing (though it certainly works as a BDD test utility library).
+Aside from better looking code, a big reason to use *ensure* is that it provides more consistent, readable, and
+informative error messages when things go wrong. See
+`Motivation and Goals <https://github.com/kislyuk/ensure#motivation-and-goals>`_ for more.
+
+%prep
+%autosetup -n ensure-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ensure -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated