summaryrefslogtreecommitdiff
path: root/python-env2.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 06:42:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 06:42:55 +0000
commit444507fa7fb1e1995dd1862b188a5e2fff081441 (patch)
treec1d52a8730642b35551286cebf9ef956f8b49727 /python-env2.spec
parent16f0bd5e4b02c5de024bb15d1f7ff70d34eed2ea (diff)
automatic import of python-env2openeuler20.03
Diffstat (limited to 'python-env2.spec')
-rw-r--r--python-env2.spec207
1 files changed, 207 insertions, 0 deletions
diff --git a/python-env2.spec b/python-env2.spec
new file mode 100644
index 0000000..c949a01
--- /dev/null
+++ b/python-env2.spec
@@ -0,0 +1,207 @@
+%global _empty_manifest_terminate_build 0
+Name: python-env2
+Version: 0.0.0
+Release: 1
+Summary: os.environ on steroids
+License: Apache Software License
+URL: https://github.com/memogarcia/env2
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/96/22/63b196fbb1cb4dabf408797c550efd59d3c241a04b663052a3ad1c1d11e4/env2-0.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# Env2
+
+os.environ on stereoids
+
+env2 allows raising errors on missing environment variables without too much bolierplate code. This is very useful when developing microservices that depends on environment variables.
+
+## How it works
+
+With env2 you can replace this:
+
+```python
+import os
+
+var = os.environ.get('key', None)
+if not var:
+ raise Exception(f'{key} not found in environment variables')
+return var
+```
+
+With this:
+
+```python
+from env2 import env2
+
+var = env2('key')
+```
+
+env2 will automatically raise on a missing key, to avoid that:
+
+```python
+from env2 import env2
+
+var = env2('key', raise_error=False)
+```
+
+env2 allows to set default values as well:
+
+```python
+from env2 import env2
+
+var = env2('key', default='key2')
+```
+
+## License
+
+This software is under [WTFPL](http://www.wtfpl.net) license
+
+%package -n python3-env2
+Summary: os.environ on steroids
+Provides: python-env2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-env2
+# Env2
+
+os.environ on stereoids
+
+env2 allows raising errors on missing environment variables without too much bolierplate code. This is very useful when developing microservices that depends on environment variables.
+
+## How it works
+
+With env2 you can replace this:
+
+```python
+import os
+
+var = os.environ.get('key', None)
+if not var:
+ raise Exception(f'{key} not found in environment variables')
+return var
+```
+
+With this:
+
+```python
+from env2 import env2
+
+var = env2('key')
+```
+
+env2 will automatically raise on a missing key, to avoid that:
+
+```python
+from env2 import env2
+
+var = env2('key', raise_error=False)
+```
+
+env2 allows to set default values as well:
+
+```python
+from env2 import env2
+
+var = env2('key', default='key2')
+```
+
+## License
+
+This software is under [WTFPL](http://www.wtfpl.net) license
+
+%package help
+Summary: Development documents and examples for env2
+Provides: python3-env2-doc
+%description help
+# Env2
+
+os.environ on stereoids
+
+env2 allows raising errors on missing environment variables without too much bolierplate code. This is very useful when developing microservices that depends on environment variables.
+
+## How it works
+
+With env2 you can replace this:
+
+```python
+import os
+
+var = os.environ.get('key', None)
+if not var:
+ raise Exception(f'{key} not found in environment variables')
+return var
+```
+
+With this:
+
+```python
+from env2 import env2
+
+var = env2('key')
+```
+
+env2 will automatically raise on a missing key, to avoid that:
+
+```python
+from env2 import env2
+
+var = env2('key', raise_error=False)
+```
+
+env2 allows to set default values as well:
+
+```python
+from env2 import env2
+
+var = env2('key', default='key2')
+```
+
+## License
+
+This software is under [WTFPL](http://www.wtfpl.net) license
+
+%prep
+%autosetup -n env2-0.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-env2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.0-1
+- Package Spec generated