summaryrefslogtreecommitdiff
path: root/python-envo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 08:31:34 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 08:31:34 +0000
commit15b21d286b14f8ad5a9df5a5679266152adbdf61 (patch)
tree949af005f054560dc63e49748497a652e2a60b99 /python-envo.spec
parent311b82189b0820be119914d5b0a48c1bc34ac4fa (diff)
automatic import of python-envo
Diffstat (limited to 'python-envo.spec')
-rw-r--r--python-envo.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-envo.spec b/python-envo.spec
new file mode 100644
index 0000000..d6ac7a9
--- /dev/null
+++ b/python-envo.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-envo
+Version: 1.2.9
+Release: 1
+Summary: Smart Environments handling - Define command hooks, file hooks and env variables in python and activate hot reloaded shells.
+License: Apache 2.0
+URL: https://pypi.org/project/envo/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7b/f2/1d7b526e721c207f96c2aabba54ed29ce33e968d1d25e7c45f773c5d40eb/envo-1.2.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-dataclasses
+Requires: python3-typing-extensions
+Requires: python3-prompt_toolkit
+Requires: python3-rhei
+Requires: python3-pygments
+Requires: python3-xonsh
+Requires: python3-xonsh
+Requires: python3-watchdog
+Requires: python3-rich
+Requires: python3-fire
+Requires: python3-loguru
+Requires: python3-globmatch
+Requires: python3-envium
+Requires: python3-colorama
+
+%description
+
+
+%package -n python3-envo
+Summary: Smart Environments handling - Define command hooks, file hooks and env variables in python and activate hot reloaded shells.
+Provides: python-envo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-envo
+
+
+%package help
+Summary: Development documents and examples for envo
+Provides: python3-envo-doc
+%description help
+
+
+%prep
+%autosetup -n envo-1.2.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-envo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.9-1
+- Package Spec generated