summaryrefslogtreecommitdiff
path: root/python-envuitest.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-envuitest.spec')
-rw-r--r--python-envuitest.spec162
1 files changed, 162 insertions, 0 deletions
diff --git a/python-envuitest.spec b/python-envuitest.spec
new file mode 100644
index 0000000..dda1bd5
--- /dev/null
+++ b/python-envuitest.spec
@@ -0,0 +1,162 @@
+%global _empty_manifest_terminate_build 0
+Name: python-envuitest
+Version: 0.0.15
+Release: 1
+Summary: Web Auto Test Framework with Selenium
+License: MIT License
+URL: https://github.com/goeasyway/EasyPlug
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d9/92/5f4d888c17a934f2d5c83287d4dfc5c77158b9ec391c355b3ffd36b76482/envuitest-0.0.15.tar.gz
+BuildArch: noarch
+
+
+%description
+# Salesforce Web Driver
+Web Auto Test Framework with Selenium For Salesforce Lightning App
+
+Function APIS:
+- login: login Salesforce's Scratch Org
+- open_url: open target url
+- click_element: click element by visibility text
+- set_value: set value to element by it's label or visibility text
+- check_table_value: check table data by record data and row_index
+
+Example:
+
+```python
+
+from selenium import webdriver
+chrome_options = webdriver.ChromeOptions()
+prefs = {"profile.default_content_setting_values.notifications" : 2}
+chrome_options.add_experimental_option("prefs",prefs)
+
+driver = webdriver.Chrome('/your path/chrome_driver/chromedriver', chrome_options=chrome_options)
+
+login(driver, 'test@example.com', 'password')
+open_url(driver, 'https://builder-playground-4380-dev-ed.lightning.force.com/lightning/n/PC_DivisionTab')
+record = {'体系编号': 'DIV007'}
+check_table_value(driver, record, False)
+click_element(driver, '新建体系', '')
+check_table_value(driver, record, True)
+
+```
+
+
+
+%package -n python3-envuitest
+Summary: Web Auto Test Framework with Selenium
+Provides: python-envuitest
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-envuitest
+# Salesforce Web Driver
+Web Auto Test Framework with Selenium For Salesforce Lightning App
+
+Function APIS:
+- login: login Salesforce's Scratch Org
+- open_url: open target url
+- click_element: click element by visibility text
+- set_value: set value to element by it's label or visibility text
+- check_table_value: check table data by record data and row_index
+
+Example:
+
+```python
+
+from selenium import webdriver
+chrome_options = webdriver.ChromeOptions()
+prefs = {"profile.default_content_setting_values.notifications" : 2}
+chrome_options.add_experimental_option("prefs",prefs)
+
+driver = webdriver.Chrome('/your path/chrome_driver/chromedriver', chrome_options=chrome_options)
+
+login(driver, 'test@example.com', 'password')
+open_url(driver, 'https://builder-playground-4380-dev-ed.lightning.force.com/lightning/n/PC_DivisionTab')
+record = {'体系编号': 'DIV007'}
+check_table_value(driver, record, False)
+click_element(driver, '新建体系', '')
+check_table_value(driver, record, True)
+
+```
+
+
+
+%package help
+Summary: Development documents and examples for envuitest
+Provides: python3-envuitest-doc
+%description help
+# Salesforce Web Driver
+Web Auto Test Framework with Selenium For Salesforce Lightning App
+
+Function APIS:
+- login: login Salesforce's Scratch Org
+- open_url: open target url
+- click_element: click element by visibility text
+- set_value: set value to element by it's label or visibility text
+- check_table_value: check table data by record data and row_index
+
+Example:
+
+```python
+
+from selenium import webdriver
+chrome_options = webdriver.ChromeOptions()
+prefs = {"profile.default_content_setting_values.notifications" : 2}
+chrome_options.add_experimental_option("prefs",prefs)
+
+driver = webdriver.Chrome('/your path/chrome_driver/chromedriver', chrome_options=chrome_options)
+
+login(driver, 'test@example.com', 'password')
+open_url(driver, 'https://builder-playground-4380-dev-ed.lightning.force.com/lightning/n/PC_DivisionTab')
+record = {'体系编号': 'DIV007'}
+check_table_value(driver, record, False)
+click_element(driver, '新建体系', '')
+check_table_value(driver, record, True)
+
+```
+
+
+
+%prep
+%autosetup -n envuitest-0.0.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-envuitest -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.15-1
+- Package Spec generated