summaryrefslogtreecommitdiff
path: root/python-exception.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 06:24:12 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 06:24:12 +0000
commit6b7fe93a05f26d490ae14a70c6fa749274c34091 (patch)
treeab8b31b6f699683c6e707aff91c0bd00b1efaeb9 /python-exception.spec
parent59c73338dd5bad0f3ee5ccdd8ff49ec5ed4da840 (diff)
automatic import of python-exception
Diffstat (limited to 'python-exception.spec')
-rw-r--r--python-exception.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-exception.spec b/python-exception.spec
new file mode 100644
index 0000000..27a0451
--- /dev/null
+++ b/python-exception.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-exception
+Version: 0.1.0
+Release: 1
+Summary: Extract unique Python exceptions with their traceback from a log file.
+License: MIT license
+URL: https://github.com/tdhopper/exception
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6a/bc/166103e2bc6c52a001ff9ea5ad80a1dada87a97a5d8e35fc2f3314375eb4/exception-0.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-exception
+Summary: Extract unique Python exceptions with their traceback from a log file.
+Provides: python-exception
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-exception
+
+
+%package help
+Summary: Development documents and examples for exception
+Provides: python3-exception-doc
+%description help
+
+
+%prep
+%autosetup -n exception-0.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-exception -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0-1
+- Package Spec generated