summaryrefslogtreecommitdiff
path: root/python-exit-codes.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-exit-codes.spec')
-rw-r--r--python-exit-codes.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-exit-codes.spec b/python-exit-codes.spec
new file mode 100644
index 0000000..96f36b0
--- /dev/null
+++ b/python-exit-codes.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-exit-codes
+Version: 1.3.0
+Release: 1
+Summary: Platform-independent exit codes.
+License: MIT
+URL: http://github.com/sixty-north/exit-codes
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f8/20/1a8671601b459a8388185ee29f98cee5965a94aeaccc6b9c926f4afec4dc/exit_codes-1.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+Requires: python3-tox
+
+%description
+
+
+%package -n python3-exit-codes
+Summary: Platform-independent exit codes.
+Provides: python-exit-codes
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-exit-codes
+
+
+%package help
+Summary: Development documents and examples for exit-codes
+Provides: python3-exit-codes-doc
+%description help
+
+
+%prep
+%autosetup -n exit-codes-1.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-exit-codes -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
+- Package Spec generated