summaryrefslogtreecommitdiff
path: root/python-factory.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-factory.spec')
-rw-r--r--python-factory.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-factory.spec b/python-factory.spec
new file mode 100644
index 0000000..ace3997
--- /dev/null
+++ b/python-factory.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Factory
+Version: 1.2
+Release: 1
+Summary: Object Oriented Currying
+License: UNKNOWN
+URL: http://code.google.com/p/python-factory/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/18/7b/342e9c93d32b21deaaded9fb929413b71c37187079bbdce4b6bae4568f47/Factory-1.2.tar.gz
+BuildArch: noarch
+
+
+%description
+Factory is an object-oriented approach to partial function application, also known as currying. The Factory module is a more powerful implementation of this pattern. Some improvements include:
+- safer, as invalid arguments are detected immediately, instead of at call time
+- intelligent support for classes, instance methods & all other callables
+- bound arguments can be inspected and modified as attributes
+- several convenient methods for (re)binding arguments
+- no "Russian dolls" of nested lambdas
+Using Factories can:
+- simplify writing callbacks
+- reduce bugs in concurrent applications
+- provide easy lazy evaluation
+
+%package -n python3-Factory
+Summary: Object Oriented Currying
+Provides: python-Factory
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Factory
+Factory is an object-oriented approach to partial function application, also known as currying. The Factory module is a more powerful implementation of this pattern. Some improvements include:
+- safer, as invalid arguments are detected immediately, instead of at call time
+- intelligent support for classes, instance methods & all other callables
+- bound arguments can be inspected and modified as attributes
+- several convenient methods for (re)binding arguments
+- no "Russian dolls" of nested lambdas
+Using Factories can:
+- simplify writing callbacks
+- reduce bugs in concurrent applications
+- provide easy lazy evaluation
+
+%package help
+Summary: Development documents and examples for Factory
+Provides: python3-Factory-doc
+%description help
+Factory is an object-oriented approach to partial function application, also known as currying. The Factory module is a more powerful implementation of this pattern. Some improvements include:
+- safer, as invalid arguments are detected immediately, instead of at call time
+- intelligent support for classes, instance methods & all other callables
+- bound arguments can be inspected and modified as attributes
+- several convenient methods for (re)binding arguments
+- no "Russian dolls" of nested lambdas
+Using Factories can:
+- simplify writing callbacks
+- reduce bugs in concurrent applications
+- provide easy lazy evaluation
+
+%prep
+%autosetup -n Factory-1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Factory -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2-1
+- Package Spec generated