summaryrefslogtreecommitdiff
path: root/python-fasjson-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-fasjson-client.spec')
-rw-r--r--python-fasjson-client.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/python-fasjson-client.spec b/python-fasjson-client.spec
new file mode 100644
index 0000000..38fbd3e
--- /dev/null
+++ b/python-fasjson-client.spec
@@ -0,0 +1,112 @@
+%global _empty_manifest_terminate_build 0
+Name: python-fasjson-client
+Version: 1.0.7
+Release: 1
+Summary: An OpenAPI client for FASJSON
+License: LGPL-3.0-or-later
+URL: https://github.com/fedora-infra/fasjson-client
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/23/2d/84efbb7e79376c9e6b02f727b2b9bc12ffe8a41fa2e750907fca0edea767/fasjson-client-1.0.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-gssapi
+Requires: python3-bravado
+Requires: python3-requests
+Requires: python3-requests-gssapi
+Requires: python3-cryptography
+Requires: python3-click
+Requires: python3-toml
+
+%description
+# fasjson-client
+
+A python client library for the FASJSON API
+
+This client uses the bravado library to build dynamic api methods based on open-api specs (version 2.0): https://github.com/Yelp/bravado
+
+The documentation is available at https://fasjson-client.readthedocs.io/
+
+## License
+
+Licensed under [lgpl-3.0](./LICENSE)
+
+
+%package -n python3-fasjson-client
+Summary: An OpenAPI client for FASJSON
+Provides: python-fasjson-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-fasjson-client
+# fasjson-client
+
+A python client library for the FASJSON API
+
+This client uses the bravado library to build dynamic api methods based on open-api specs (version 2.0): https://github.com/Yelp/bravado
+
+The documentation is available at https://fasjson-client.readthedocs.io/
+
+## License
+
+Licensed under [lgpl-3.0](./LICENSE)
+
+
+%package help
+Summary: Development documents and examples for fasjson-client
+Provides: python3-fasjson-client-doc
+%description help
+# fasjson-client
+
+A python client library for the FASJSON API
+
+This client uses the bravado library to build dynamic api methods based on open-api specs (version 2.0): https://github.com/Yelp/bravado
+
+The documentation is available at https://fasjson-client.readthedocs.io/
+
+## License
+
+Licensed under [lgpl-3.0](./LICENSE)
+
+
+%prep
+%autosetup -n fasjson-client-1.0.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-fasjson-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.7-1
+- Package Spec generated