summaryrefslogtreecommitdiff
path: root/python-fastapi-sqlalchemy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 10:09:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 10:09:27 +0000
commit336f96c393a227f02d1a6f4ff5c4f725eb40519d (patch)
tree6ed859cd0922145fb974c20d887dfcedce1a9ba7 /python-fastapi-sqlalchemy.spec
parent5a68f6d5ab64aa56d648abea87f4e1c3bd6f47cc (diff)
automatic import of python-fastapi-sqlalchemy
Diffstat (limited to 'python-fastapi-sqlalchemy.spec')
-rw-r--r--python-fastapi-sqlalchemy.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-fastapi-sqlalchemy.spec b/python-fastapi-sqlalchemy.spec
new file mode 100644
index 0000000..7118d4d
--- /dev/null
+++ b/python-fastapi-sqlalchemy.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-FastAPI-SQLAlchemy
+Version: 0.2.1
+Release: 1
+Summary: Adds simple SQLAlchemy support to FastAPI
+License: MIT
+URL: https://github.com/mfreeborn/fastapi-sqlalchemy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/1d/c08c99b2be52d822323840a7acc8f17df5bc3963e5e3431b4cedc0838b2f/FastAPI-SQLAlchemy-0.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-starlette
+Requires: python3-SQLAlchemy
+
+%description
+FastAPI-SQLAlchemy provides a simple integration between FastAPI_ and SQLAlchemy_ in your application. It gives access to useful helpers to facilitate the completion of common tasks.
+
+%package -n python3-FastAPI-SQLAlchemy
+Summary: Adds simple SQLAlchemy support to FastAPI
+Provides: python-FastAPI-SQLAlchemy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-FastAPI-SQLAlchemy
+FastAPI-SQLAlchemy provides a simple integration between FastAPI_ and SQLAlchemy_ in your application. It gives access to useful helpers to facilitate the completion of common tasks.
+
+%package help
+Summary: Development documents and examples for FastAPI-SQLAlchemy
+Provides: python3-FastAPI-SQLAlchemy-doc
+%description help
+FastAPI-SQLAlchemy provides a simple integration between FastAPI_ and SQLAlchemy_ in your application. It gives access to useful helpers to facilitate the completion of common tasks.
+
+%prep
+%autosetup -n FastAPI-SQLAlchemy-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-FastAPI-SQLAlchemy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated