summaryrefslogtreecommitdiff
path: root/python-fastdiff.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 12:43:05 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 12:43:05 +0000
commitf5c0daba1ff78c8addbc4a7f60da065e6266e37f (patch)
tree190259709a199d2f4c14b7832585deaddde7456f /python-fastdiff.spec
parent2a2fe66962f52a8e3793b8a21295e94024230496 (diff)
automatic import of python-fastdiff
Diffstat (limited to 'python-fastdiff.spec')
-rw-r--r--python-fastdiff.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-fastdiff.spec b/python-fastdiff.spec
new file mode 100644
index 0000000..7b3ecfc
--- /dev/null
+++ b/python-fastdiff.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-fastdiff
+Version: 0.3.0
+Release: 1
+Summary: A fast native implementation of diff algorithm with a pure python fallback
+License: MIT license
+URL: https://github.com/syrusakbary/fastdiff
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/0e/5cec0653411663dab4850d2cf04be21e36fd604b7669af546062076e5a07/fastdiff-0.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-wasmer
+Requires: python3-wasmer-compiler-cranelift
+
+%description
+
+
+%package -n python3-fastdiff
+Summary: A fast native implementation of diff algorithm with a pure python fallback
+Provides: python-fastdiff
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-fastdiff
+
+
+%package help
+Summary: Development documents and examples for fastdiff
+Provides: python3-fastdiff-doc
+%description help
+
+
+%prep
+%autosetup -n fastdiff-0.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-fastdiff -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
+- Package Spec generated