summaryrefslogtreecommitdiff
path: root/python-ffsubsync.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 09:37:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 09:37:32 +0000
commitb6ff8d39f9aba480e45e48c3ef60052603905ba6 (patch)
tree9c698e14bf460ed2a92e3f1efbf3a60b1958760f /python-ffsubsync.spec
parent26a5b063246594354f41a84ac85c92b7e714a04c (diff)
automatic import of python-ffsubsync
Diffstat (limited to 'python-ffsubsync.spec')
-rw-r--r--python-ffsubsync.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-ffsubsync.spec b/python-ffsubsync.spec
new file mode 100644
index 0000000..a382a0e
--- /dev/null
+++ b/python-ffsubsync.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ffsubsync
+Version: 0.4.25
+Release: 1
+Summary: Language-agnostic synchronization of subtitles with video.
+License: MIT
+URL: https://github.com/smacke/ffsubsync
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/45/59/06f2f27bf98823898056194c8ebf838d0d6238118e10b33e2e53f2d5c8b8/ffsubsync-0.4.25.tar.gz
+BuildArch: noarch
+
+Requires: python3-auditok
+Requires: python3-charset-normalizer
+Requires: python3-faust-cchardet
+Requires: python3-ffmpeg-python
+Requires: python3-future
+Requires: python3-numpy
+Requires: python3-rich
+Requires: python3-six
+Requires: python3-srt
+Requires: python3-tqdm
+Requires: python3-typing-extensions
+Requires: python3-webrtcvad
+Requires: python3-webrtcvad-wheels
+Requires: python3-pysubs2
+Requires: python3-chardet
+Requires: python3-pysubs2
+
+%description
+[![CI Status](https://github.com/smacke/ffsubsync/workflows/ffsubsync/badge.svg)](https://github.com/smacke/ffsubsync/actions)
+[![Support Ukraine](https://badgen.net/badge/support/UKRAINE/?color=0057B8&labelColor=FFD700)](https://github.com/vshymanskyy/StandWithUkraine/blob/main/docs/README.md)
+[![Checked with mypy](http://www.mypy-lang.org/static/mypy_badge.svg)](http://mypy-lang.org/)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![License: MIT](https://img.shields.io/badge/License-MIT-maroon.svg)](https://opensource.org/licenses/MIT)
+[![Python Versions](https://img.shields.io/pypi/pyversions/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+[![Documentation Status](https://readthedocs.org/projects/ffsubsync/badge/?version=latest)](https://ffsubsync.readthedocs.io/en/latest/?badge=latest)
+[![PyPI Version](https://img.shields.io/pypi/v/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+Language-agnostic automatic synchronization of subtitles with video, so that
+subtitles are aligned to the correct starting point within the video.
+Turn this: | Into this:
+![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-wrong.gif) | ![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-correct.gif)
+
+%package -n python3-ffsubsync
+Summary: Language-agnostic synchronization of subtitles with video.
+Provides: python-ffsubsync
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ffsubsync
+[![CI Status](https://github.com/smacke/ffsubsync/workflows/ffsubsync/badge.svg)](https://github.com/smacke/ffsubsync/actions)
+[![Support Ukraine](https://badgen.net/badge/support/UKRAINE/?color=0057B8&labelColor=FFD700)](https://github.com/vshymanskyy/StandWithUkraine/blob/main/docs/README.md)
+[![Checked with mypy](http://www.mypy-lang.org/static/mypy_badge.svg)](http://mypy-lang.org/)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![License: MIT](https://img.shields.io/badge/License-MIT-maroon.svg)](https://opensource.org/licenses/MIT)
+[![Python Versions](https://img.shields.io/pypi/pyversions/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+[![Documentation Status](https://readthedocs.org/projects/ffsubsync/badge/?version=latest)](https://ffsubsync.readthedocs.io/en/latest/?badge=latest)
+[![PyPI Version](https://img.shields.io/pypi/v/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+Language-agnostic automatic synchronization of subtitles with video, so that
+subtitles are aligned to the correct starting point within the video.
+Turn this: | Into this:
+![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-wrong.gif) | ![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-correct.gif)
+
+%package help
+Summary: Development documents and examples for ffsubsync
+Provides: python3-ffsubsync-doc
+%description help
+[![CI Status](https://github.com/smacke/ffsubsync/workflows/ffsubsync/badge.svg)](https://github.com/smacke/ffsubsync/actions)
+[![Support Ukraine](https://badgen.net/badge/support/UKRAINE/?color=0057B8&labelColor=FFD700)](https://github.com/vshymanskyy/StandWithUkraine/blob/main/docs/README.md)
+[![Checked with mypy](http://www.mypy-lang.org/static/mypy_badge.svg)](http://mypy-lang.org/)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![License: MIT](https://img.shields.io/badge/License-MIT-maroon.svg)](https://opensource.org/licenses/MIT)
+[![Python Versions](https://img.shields.io/pypi/pyversions/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+[![Documentation Status](https://readthedocs.org/projects/ffsubsync/badge/?version=latest)](https://ffsubsync.readthedocs.io/en/latest/?badge=latest)
+[![PyPI Version](https://img.shields.io/pypi/v/ffsubsync.svg)](https://pypi.org/project/ffsubsync)
+Language-agnostic automatic synchronization of subtitles with video, so that
+subtitles are aligned to the correct starting point within the video.
+Turn this: | Into this:
+![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-wrong.gif) | ![](https://raw.githubusercontent.com/smacke/ffsubsync/master/resources/img/tearing-me-apart-correct.gif)
+
+%prep
+%autosetup -n ffsubsync-0.4.25
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ffsubsync -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.25-1
+- Package Spec generated