From f798e40cfda308d5b05b3c962731d3b0d26911ab Mon Sep 17 00:00:00 2001
From: CoprDistGit
Date: Tue, 11 Apr 2023 22:58:06 +0000
Subject: automatic import of python-fiftyone
---
python-fiftyone.spec | 168 +++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 168 insertions(+)
create mode 100644 python-fiftyone.spec
(limited to 'python-fiftyone.spec')
diff --git a/python-fiftyone.spec b/python-fiftyone.spec
new file mode 100644
index 0000000..56a6723
--- /dev/null
+++ b/python-fiftyone.spec
@@ -0,0 +1,168 @@
+%global _empty_manifest_terminate_build 0
+Name: python-fiftyone
+Version: 0.20.1
+Release: 1
+Summary: FiftyOne: the open-source tool for building high-quality datasets and computer vision models
+License: Apache
+URL: https://github.com/voxel51/fiftyone
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/75/255a8554efbf168a00e6e4f5be99884a33156d2e07cda42c59532e44bc12/fiftyone-0.20.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiofiles
+Requires: python3-argcomplete
+Requires: python3-boto3
+Requires: python3-cachetools
+Requires: python3-dacite
+Requires: python3-Deprecated
+Requires: python3-eventlet
+Requires: python3-ftfy
+Requires: python3-future
+Requires: python3-hypercorn
+Requires: python3-Jinja2
+Requires: python3-kaleido
+Requires: python3-matplotlib
+Requires: python3-mongoengine
+Requires: python3-motor
+Requires: python3-numpy
+Requires: python3-packaging
+Requires: python3-pandas
+Requires: python3-Pillow
+Requires: python3-plotly
+Requires: python3-pprintpp
+Requires: python3-psutil
+Requires: python3-pymongo
+Requires: python3-pytz
+Requires: python3-PyYAML
+Requires: python3-regex
+Requires: python3-retrying
+Requires: python3-scikit-learn
+Requires: python3-scikit-image
+Requires: python3-setuptools
+Requires: python3-sseclient-py
+Requires: python3-sse-starlette
+Requires: python3-starlette
+Requires: python3-strawberry-graphql
+Requires: python3-tabulate
+Requires: python3-xmltodict
+Requires: python3-universal-analytics-python3
+Requires: python3-fiftyone-brain
+Requires: python3-fiftyone-db
+Requires: python3-voxel51-eta
+Requires: python3-opencv-python-headless
+Requires: python3-fiftyone-desktop
+
+%description
+
+Website •
+Docs •
+Try it Now •
+Tutorials •
+Examples •
+Blog •
+Community
+[](https://pypi.org/project/fiftyone)
+[](https://pypi.org/project/fiftyone)
+[](https://pepy.tech/project/fiftyone)
+[](https://github.com/voxel51/fiftyone/actions?query=workflow%3ABuild)
+[](LICENSE)
+[](https://join.slack.com/t/fiftyone-users/shared_invite/zt-s6936w7b-2R5eVPJoUw008wP7miJmPQ)
+[](https://medium.com/voxel51)
+[](https://share.hsforms.com/1zpJ60ggaQtOoVeBqIZdaaA2ykyk)
+[](https://twitter.com/voxel51)
+[](https://fiftyone.ai)
+
+
+%package -n python3-fiftyone
+Summary: FiftyOne: the open-source tool for building high-quality datasets and computer vision models
+Provides: python-fiftyone
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-fiftyone
+
+Website •
+Docs •
+Try it Now •
+Tutorials •
+Examples •
+Blog •
+Community
+[](https://pypi.org/project/fiftyone)
+[](https://pypi.org/project/fiftyone)
+[](https://pepy.tech/project/fiftyone)
+[](https://github.com/voxel51/fiftyone/actions?query=workflow%3ABuild)
+[](LICENSE)
+[](https://join.slack.com/t/fiftyone-users/shared_invite/zt-s6936w7b-2R5eVPJoUw008wP7miJmPQ)
+[](https://medium.com/voxel51)
+[](https://share.hsforms.com/1zpJ60ggaQtOoVeBqIZdaaA2ykyk)
+[](https://twitter.com/voxel51)
+[](https://fiftyone.ai)
+
+
+%package help
+Summary: Development documents and examples for fiftyone
+Provides: python3-fiftyone-doc
+%description help
+
+Website •
+Docs •
+Try it Now •
+Tutorials •
+Examples •
+Blog •
+Community
+[](https://pypi.org/project/fiftyone)
+[](https://pypi.org/project/fiftyone)
+[](https://pepy.tech/project/fiftyone)
+[](https://github.com/voxel51/fiftyone/actions?query=workflow%3ABuild)
+[](LICENSE)
+[](https://join.slack.com/t/fiftyone-users/shared_invite/zt-s6936w7b-2R5eVPJoUw008wP7miJmPQ)
+[](https://medium.com/voxel51)
+[](https://share.hsforms.com/1zpJ60ggaQtOoVeBqIZdaaA2ykyk)
+[](https://twitter.com/voxel51)
+[](https://fiftyone.ai)
+
+
+%prep
+%autosetup -n fiftyone-0.20.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-fiftyone -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot - 0.20.1-1
+- Package Spec generated
--
cgit v1.2.3