summaryrefslogtreecommitdiff
path: root/python-filesplit.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 01:40:29 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 01:40:29 +0000
commit88e642c83014c7869d0d4e5ba829f74e95498015 (patch)
tree1acedec2cadc60557e2924a627c345c309753d76 /python-filesplit.spec
parentfa472da04c0c38439dedcc07c5026ea44c006519 (diff)
automatic import of python-filesplit
Diffstat (limited to 'python-filesplit.spec')
-rw-r--r--python-filesplit.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-filesplit.spec b/python-filesplit.spec
new file mode 100644
index 0000000..460d513
--- /dev/null
+++ b/python-filesplit.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-filesplit
+Version: 4.0.1
+Release: 1
+Summary: Python module that is capable of splitting files and merging it back.
+License: MIT License
+URL: https://github.com/ram-jayapalan/filesplit
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a4/d5/d150c286beccb9897c72a7cfd161a00ad23914a5a7e64a9af909449eb9f6/filesplit-4.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+File splitting and merging made easy for python programmers!
+This module
+ * Can split files of any size into multiple chunks and also merge them back.
+ * Can handle both structured and unstructured files.
+
+%package -n python3-filesplit
+Summary: Python module that is capable of splitting files and merging it back.
+Provides: python-filesplit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-filesplit
+File splitting and merging made easy for python programmers!
+This module
+ * Can split files of any size into multiple chunks and also merge them back.
+ * Can handle both structured and unstructured files.
+
+%package help
+Summary: Development documents and examples for filesplit
+Provides: python3-filesplit-doc
+%description help
+File splitting and merging made easy for python programmers!
+This module
+ * Can split files of any size into multiple chunks and also merge them back.
+ * Can handle both structured and unstructured files.
+
+%prep
+%autosetup -n filesplit-4.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-filesplit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.1-1
+- Package Spec generated