summaryrefslogtreecommitdiff
path: root/python-flake8-markdown.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 21:43:26 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 21:43:26 +0000
commitb67d449c05464da409089677c8be205590e284c4 (patch)
treef1a40204d3146c8096620d03d3d546fd65ebe644 /python-flake8-markdown.spec
parent8e7d59872bfacd7c02f8b49572068ab57acf5246 (diff)
automatic import of python-flake8-markdown
Diffstat (limited to 'python-flake8-markdown.spec')
-rw-r--r--python-flake8-markdown.spec367
1 files changed, 367 insertions, 0 deletions
diff --git a/python-flake8-markdown.spec b/python-flake8-markdown.spec
new file mode 100644
index 0000000..6a2901f
--- /dev/null
+++ b/python-flake8-markdown.spec
@@ -0,0 +1,367 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flake8-markdown
+Version: 0.4.0
+Release: 1
+Summary: Lints Python code blocks in Markdown files using flake8
+License: MIT
+URL: https://github.com/johnfraney/flake8-markdown
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6a/ba/4498cfad6053c444a2038dae976a6acbf8299236c6747ed68f7844b31aa0/flake8-markdown-0.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-flake8
+
+%description
+# Flake8 Markdown
+
+[
+![PyPI](https://img.shields.io/pypi/v/flake8-markdown.svg)
+![PyPI](https://img.shields.io/pypi/pyversions/flake8-markdown.svg)
+![PyPI](https://img.shields.io/github/license/johnfraney/flake8-markdown.svg)
+](https://pypi.org/project/flake8-markdown/)
+[![TravisCI](https://travis-ci.com/johnfraney/flake8-markdown.svg?branch=master)](https://travis-ci.com/johnfraney/flake8-markdown)
+
+Flake8 Markdown lints [GitHub-style Python code blocks](https://help.github.com/en/articles/creating-and-highlighting-code-blocks#fenced-code-blocks) in Markdown files using [`flake8`](https://flake8.readthedocs.io/en/stable/).
+
+This package helps improve a Python project's documentation by ensuring that code samples are error-free.
+
+## Features
+
+- Lints code blocks containing regular Python and Python interpreter code ([`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer))
+- [pre-commit](#pre-commit-hook) hook to lint on commit
+
+## Installation
+
+Flake8 Markdown can be installed from PyPI using `pip` or your package manager of choice:
+
+```
+pip install flake8-markdown
+```
+
+## Usage
+
+### CLI
+
+You can use Flake8 Markdown as a CLI tool using the `flake8-markdown` command.
+
+`flake8-markdown` accepts one or more [globs](https://docs.python.org/3.7/library/glob.html) as its arguments.
+
+Example:
+
+```console
+$ flake8-markdown "tests/samples/*.md"
+tests/samples/emphasized_lines.md:6:1: F821 undefined name 'emphasized_imaginary_function'
+tests/samples/basic.md:8:48: E999 SyntaxError: EOL while scanning string literal
+tests/samples/basic.md:14:7: F821 undefined name 'undefined_variable'
+```
+
+### pre-commit hook
+
+You can also add `flake8-markdown` to your project using [pre-commit](https://pre-commit.com/). When configured, any staged Markdown files will be linted using `flake8-markdown` once you run `git commit`.
+
+To enable this hook in your local repository, add the following `repo` to your `.pre-commit-config.yaml` file:
+
+```yaml
+# .pre-commit-config.yaml
+repos:
+ - repo: https://github.com/johnfraney/flake8-markdown
+ rev: v0.4.0
+ hooks:
+ - id: flake8-markdown
+```
+
+## Code of Conduct
+
+Everyone interacting in the project's codebases, issue trackers, chat rooms, and mailing lists is expected to follow the [PyPA Code of Conduct](https://www.pypa.io/en/latest/code-of-conduct/).
+
+## History
+
+### [0.4.0] - 2022-09-11
+
+#### Added
+
+- Added support for `flake8` v5
+- Added support for `python` 3.10
+
+#### Removed
+
+- Dropped support for `python` 3.6
+
+### [0.3.0] - 2021-10-19
+
+#### Added
+
+- Added support for `flake8` v4
+
+### [0.2.0] - 2019-06-14
+
+#### Added
+
+- [`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer) code block support
+
+### [0.1.1] - 2019-05-19
+
+#### Changed
+
+- Fixed pre-commit example in README
+
+### [0.1.0] - 2019-05-19
+
+#### Added
+
+- Added code for initial release
+
+
+%package -n python3-flake8-markdown
+Summary: Lints Python code blocks in Markdown files using flake8
+Provides: python-flake8-markdown
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flake8-markdown
+# Flake8 Markdown
+
+[
+![PyPI](https://img.shields.io/pypi/v/flake8-markdown.svg)
+![PyPI](https://img.shields.io/pypi/pyversions/flake8-markdown.svg)
+![PyPI](https://img.shields.io/github/license/johnfraney/flake8-markdown.svg)
+](https://pypi.org/project/flake8-markdown/)
+[![TravisCI](https://travis-ci.com/johnfraney/flake8-markdown.svg?branch=master)](https://travis-ci.com/johnfraney/flake8-markdown)
+
+Flake8 Markdown lints [GitHub-style Python code blocks](https://help.github.com/en/articles/creating-and-highlighting-code-blocks#fenced-code-blocks) in Markdown files using [`flake8`](https://flake8.readthedocs.io/en/stable/).
+
+This package helps improve a Python project's documentation by ensuring that code samples are error-free.
+
+## Features
+
+- Lints code blocks containing regular Python and Python interpreter code ([`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer))
+- [pre-commit](#pre-commit-hook) hook to lint on commit
+
+## Installation
+
+Flake8 Markdown can be installed from PyPI using `pip` or your package manager of choice:
+
+```
+pip install flake8-markdown
+```
+
+## Usage
+
+### CLI
+
+You can use Flake8 Markdown as a CLI tool using the `flake8-markdown` command.
+
+`flake8-markdown` accepts one or more [globs](https://docs.python.org/3.7/library/glob.html) as its arguments.
+
+Example:
+
+```console
+$ flake8-markdown "tests/samples/*.md"
+tests/samples/emphasized_lines.md:6:1: F821 undefined name 'emphasized_imaginary_function'
+tests/samples/basic.md:8:48: E999 SyntaxError: EOL while scanning string literal
+tests/samples/basic.md:14:7: F821 undefined name 'undefined_variable'
+```
+
+### pre-commit hook
+
+You can also add `flake8-markdown` to your project using [pre-commit](https://pre-commit.com/). When configured, any staged Markdown files will be linted using `flake8-markdown` once you run `git commit`.
+
+To enable this hook in your local repository, add the following `repo` to your `.pre-commit-config.yaml` file:
+
+```yaml
+# .pre-commit-config.yaml
+repos:
+ - repo: https://github.com/johnfraney/flake8-markdown
+ rev: v0.4.0
+ hooks:
+ - id: flake8-markdown
+```
+
+## Code of Conduct
+
+Everyone interacting in the project's codebases, issue trackers, chat rooms, and mailing lists is expected to follow the [PyPA Code of Conduct](https://www.pypa.io/en/latest/code-of-conduct/).
+
+## History
+
+### [0.4.0] - 2022-09-11
+
+#### Added
+
+- Added support for `flake8` v5
+- Added support for `python` 3.10
+
+#### Removed
+
+- Dropped support for `python` 3.6
+
+### [0.3.0] - 2021-10-19
+
+#### Added
+
+- Added support for `flake8` v4
+
+### [0.2.0] - 2019-06-14
+
+#### Added
+
+- [`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer) code block support
+
+### [0.1.1] - 2019-05-19
+
+#### Changed
+
+- Fixed pre-commit example in README
+
+### [0.1.0] - 2019-05-19
+
+#### Added
+
+- Added code for initial release
+
+
+%package help
+Summary: Development documents and examples for flake8-markdown
+Provides: python3-flake8-markdown-doc
+%description help
+# Flake8 Markdown
+
+[
+![PyPI](https://img.shields.io/pypi/v/flake8-markdown.svg)
+![PyPI](https://img.shields.io/pypi/pyversions/flake8-markdown.svg)
+![PyPI](https://img.shields.io/github/license/johnfraney/flake8-markdown.svg)
+](https://pypi.org/project/flake8-markdown/)
+[![TravisCI](https://travis-ci.com/johnfraney/flake8-markdown.svg?branch=master)](https://travis-ci.com/johnfraney/flake8-markdown)
+
+Flake8 Markdown lints [GitHub-style Python code blocks](https://help.github.com/en/articles/creating-and-highlighting-code-blocks#fenced-code-blocks) in Markdown files using [`flake8`](https://flake8.readthedocs.io/en/stable/).
+
+This package helps improve a Python project's documentation by ensuring that code samples are error-free.
+
+## Features
+
+- Lints code blocks containing regular Python and Python interpreter code ([`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer))
+- [pre-commit](#pre-commit-hook) hook to lint on commit
+
+## Installation
+
+Flake8 Markdown can be installed from PyPI using `pip` or your package manager of choice:
+
+```
+pip install flake8-markdown
+```
+
+## Usage
+
+### CLI
+
+You can use Flake8 Markdown as a CLI tool using the `flake8-markdown` command.
+
+`flake8-markdown` accepts one or more [globs](https://docs.python.org/3.7/library/glob.html) as its arguments.
+
+Example:
+
+```console
+$ flake8-markdown "tests/samples/*.md"
+tests/samples/emphasized_lines.md:6:1: F821 undefined name 'emphasized_imaginary_function'
+tests/samples/basic.md:8:48: E999 SyntaxError: EOL while scanning string literal
+tests/samples/basic.md:14:7: F821 undefined name 'undefined_variable'
+```
+
+### pre-commit hook
+
+You can also add `flake8-markdown` to your project using [pre-commit](https://pre-commit.com/). When configured, any staged Markdown files will be linted using `flake8-markdown` once you run `git commit`.
+
+To enable this hook in your local repository, add the following `repo` to your `.pre-commit-config.yaml` file:
+
+```yaml
+# .pre-commit-config.yaml
+repos:
+ - repo: https://github.com/johnfraney/flake8-markdown
+ rev: v0.4.0
+ hooks:
+ - id: flake8-markdown
+```
+
+## Code of Conduct
+
+Everyone interacting in the project's codebases, issue trackers, chat rooms, and mailing lists is expected to follow the [PyPA Code of Conduct](https://www.pypa.io/en/latest/code-of-conduct/).
+
+## History
+
+### [0.4.0] - 2022-09-11
+
+#### Added
+
+- Added support for `flake8` v5
+- Added support for `python` 3.10
+
+#### Removed
+
+- Dropped support for `python` 3.6
+
+### [0.3.0] - 2021-10-19
+
+#### Added
+
+- Added support for `flake8` v4
+
+### [0.2.0] - 2019-06-14
+
+#### Added
+
+- [`pycon`](http://pygments.org/docs/lexers/#pygments.lexers.python.PythonConsoleLexer) code block support
+
+### [0.1.1] - 2019-05-19
+
+#### Changed
+
+- Fixed pre-commit example in README
+
+### [0.1.0] - 2019-05-19
+
+#### Added
+
+- Added code for initial release
+
+
+%prep
+%autosetup -n flake8-markdown-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flake8-markdown -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated