summaryrefslogtreecommitdiff
path: root/python-flake8-no-pep420.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flake8-no-pep420.spec')
-rw-r--r--python-flake8-no-pep420.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-flake8-no-pep420.spec b/python-flake8-no-pep420.spec
new file mode 100644
index 0000000..22772cb
--- /dev/null
+++ b/python-flake8-no-pep420.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flake8-no-pep420
+Version: 2.4.0
+Release: 1
+Summary: A flake8 plugin to ban PEP-420 implicit namespace packages.
+License: MIT
+URL: https://github.com/adamchainz/flake8-no-pep420
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e6/11/fb709b4fbcd1419003e4e1e046199c3a01d4111a8e99a3a8800cd1b88373/flake8_no_pep420-2.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-flake8
+Requires: python3-importlib-metadata
+
+%description
+
+
+%package -n python3-flake8-no-pep420
+Summary: A flake8 plugin to ban PEP-420 implicit namespace packages.
+Provides: python-flake8-no-pep420
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flake8-no-pep420
+
+
+%package help
+Summary: Development documents and examples for flake8-no-pep420
+Provides: python3-flake8-no-pep420-doc
+%description help
+
+
+%prep
+%autosetup -n flake8-no-pep420-2.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flake8-no-pep420 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.0-1
+- Package Spec generated