summaryrefslogtreecommitdiff
path: root/python-flamyngo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 03:27:48 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 03:27:48 +0000
commit0f4ccaf97fa6618a77c12b7778e3bb8f1cb6d7a3 (patch)
tree5c4a8bc7605145613d661fa88bbada493fe7fe25 /python-flamyngo.spec
parent5ac32877c0ecf47cf3af17a9464f1d19061e34bf (diff)
automatic import of python-flamyngo
Diffstat (limited to 'python-flamyngo.spec')
-rw-r--r--python-flamyngo.spec109
1 files changed, 109 insertions, 0 deletions
diff --git a/python-flamyngo.spec b/python-flamyngo.spec
new file mode 100644
index 0000000..949e4f5
--- /dev/null
+++ b/python-flamyngo.spec
@@ -0,0 +1,109 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flamyngo
+Version: 1.2.1
+Release: 1
+Summary: Flamyngo is a customizable Flask frontend for MongoDB.
+License: BSD
+URL: https://github.com/materialsvirtuallab/flamyngo
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/57/4efe8b34547ed49bb431881c0b41bff6d27b56eb68cd728b15932f3a7309/flamyngo-1.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-flask
+Requires: python3-pyyaml
+Requires: python3-monty
+Requires: python3-pymongo
+
+%description
+
+Flamyngo is a customizable Flask frontend for MongoDB.
+
+At the most basic level, the aim is to delegate most settings to a YAML
+configuration file, which then allows the underlying code to be reused for
+any conceivable collection.
+
+Detailed usage instructions are available at the project's `Github page
+<https://github.com/materialsvirtuallab/flamyngo>`_.
+
+
+
+
+%package -n python3-flamyngo
+Summary: Flamyngo is a customizable Flask frontend for MongoDB.
+Provides: python-flamyngo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flamyngo
+
+Flamyngo is a customizable Flask frontend for MongoDB.
+
+At the most basic level, the aim is to delegate most settings to a YAML
+configuration file, which then allows the underlying code to be reused for
+any conceivable collection.
+
+Detailed usage instructions are available at the project's `Github page
+<https://github.com/materialsvirtuallab/flamyngo>`_.
+
+
+
+
+%package help
+Summary: Development documents and examples for flamyngo
+Provides: python3-flamyngo-doc
+%description help
+
+Flamyngo is a customizable Flask frontend for MongoDB.
+
+At the most basic level, the aim is to delegate most settings to a YAML
+configuration file, which then allows the underlying code to be reused for
+any conceivable collection.
+
+Detailed usage instructions are available at the project's `Github page
+<https://github.com/materialsvirtuallab/flamyngo>`_.
+
+
+
+
+%prep
+%autosetup -n flamyngo-1.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flamyngo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.1-1
+- Package Spec generated