summaryrefslogtreecommitdiff
path: root/python-flask-accept.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-accept.spec')
-rw-r--r--python-flask-accept.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-flask-accept.spec b/python-flask-accept.spec
new file mode 100644
index 0000000..e6bcbfa
--- /dev/null
+++ b/python-flask-accept.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flask_accept
+Version: 0.0.6
+Release: 1
+Summary: Custom Accept header routing support for Flask
+License: MIT License
+URL: http://github.com/di/flask-accept
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/54/de4111e7ef8450bbfec187cd8e066134b2b46df679b0ad59221fd421d26d/flask_accept-0.0.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-flask
+
+%description
+
+
+%package -n python3-flask_accept
+Summary: Custom Accept header routing support for Flask
+Provides: python-flask_accept
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flask_accept
+
+
+%package help
+Summary: Development documents and examples for flask_accept
+Provides: python3-flask_accept-doc
+%description help
+
+
+%prep
+%autosetup -n flask_accept-0.0.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flask_accept -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.6-1
+- Package Spec generated