summaryrefslogtreecommitdiff
path: root/python-flask-replit-auth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-replit-auth.spec')
-rw-r--r--python-flask-replit-auth.spec242
1 files changed, 242 insertions, 0 deletions
diff --git a/python-flask-replit-auth.spec b/python-flask-replit-auth.spec
new file mode 100644
index 0000000..77f6f3d
--- /dev/null
+++ b/python-flask-replit-auth.spec
@@ -0,0 +1,242 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flask-replit-auth
+Version: 1.1.1
+Release: 1
+Summary: Brings replit auth to flask.
+License: MIT License
+URL: https://replit.com/@EpicCodeWizard/flaskreplitauth
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/0b/0519c32c3fb0095c5ac850edcca8a33cd468a50e8c7284c6c4e7f59e848b/flask_replit_auth-1.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-flask
+
+%description
+# The Unofficial Replit Auth Flask Extension
+Replit authentication is an amazing thing. This package provides an easy way to use it.
+```python
+from flask_replit_auth import replit_auth
+from flask import request, Flask
+
+app = Flask(__name__)
+replit_auth(app)
+
+@app.route("/")
+def index():
+ if request.user:
+ return request.user['username']
+ else:
+ return 'Not logged in!'
+
+if __name__ == "__main__":
+ app.run(host='0.0.0.0')
+```
+Initialize replit auth on your app by calling ```replit_auth(app)```, after creating your flask app. To get information, call ```request.user```, which will either return ```None``` or a ```dict``` with the information.
+# Replit Auth - Frontend
+```js
+var button = document.getElementById('login_with_replit');
+
+if (location.protocol !== 'https:') {
+ alert('Replit auth requires https!');
+}
+
+button.onclick = function() {
+ window.addEventListener('message', authComplete);
+
+ var h = 500;
+ var w = 350;
+ var left = (screen.width / 2) - ( w / 2);
+ var top = (screen.height / 2) - (h / 2);
+
+ var authWindow = window.open('https://replit.com/auth_with_repl_site?domain=' + location.host, '_blank', 'modal=yes, toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=' + w + ', height=' + h + ', top=' + top + ', left=' + left)
+
+ function authComplete(e) {
+ if (e.data !== 'auth_complete') {
+ return;
+ }
+
+ window.removeEventListener('message', authComplete);
+
+ authWindow.close();
+
+ // Reload the page to get the credentials.
+ location.reload();
+ }
+}
+```
+Usage:
+1. Apply the javascript code above to your website.
+2. Set the ```id``` of you login button to ```login_with_replit```.
+
+
+
+%package -n python3-flask-replit-auth
+Summary: Brings replit auth to flask.
+Provides: python-flask-replit-auth
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flask-replit-auth
+# The Unofficial Replit Auth Flask Extension
+Replit authentication is an amazing thing. This package provides an easy way to use it.
+```python
+from flask_replit_auth import replit_auth
+from flask import request, Flask
+
+app = Flask(__name__)
+replit_auth(app)
+
+@app.route("/")
+def index():
+ if request.user:
+ return request.user['username']
+ else:
+ return 'Not logged in!'
+
+if __name__ == "__main__":
+ app.run(host='0.0.0.0')
+```
+Initialize replit auth on your app by calling ```replit_auth(app)```, after creating your flask app. To get information, call ```request.user```, which will either return ```None``` or a ```dict``` with the information.
+# Replit Auth - Frontend
+```js
+var button = document.getElementById('login_with_replit');
+
+if (location.protocol !== 'https:') {
+ alert('Replit auth requires https!');
+}
+
+button.onclick = function() {
+ window.addEventListener('message', authComplete);
+
+ var h = 500;
+ var w = 350;
+ var left = (screen.width / 2) - ( w / 2);
+ var top = (screen.height / 2) - (h / 2);
+
+ var authWindow = window.open('https://replit.com/auth_with_repl_site?domain=' + location.host, '_blank', 'modal=yes, toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=' + w + ', height=' + h + ', top=' + top + ', left=' + left)
+
+ function authComplete(e) {
+ if (e.data !== 'auth_complete') {
+ return;
+ }
+
+ window.removeEventListener('message', authComplete);
+
+ authWindow.close();
+
+ // Reload the page to get the credentials.
+ location.reload();
+ }
+}
+```
+Usage:
+1. Apply the javascript code above to your website.
+2. Set the ```id``` of you login button to ```login_with_replit```.
+
+
+
+%package help
+Summary: Development documents and examples for flask-replit-auth
+Provides: python3-flask-replit-auth-doc
+%description help
+# The Unofficial Replit Auth Flask Extension
+Replit authentication is an amazing thing. This package provides an easy way to use it.
+```python
+from flask_replit_auth import replit_auth
+from flask import request, Flask
+
+app = Flask(__name__)
+replit_auth(app)
+
+@app.route("/")
+def index():
+ if request.user:
+ return request.user['username']
+ else:
+ return 'Not logged in!'
+
+if __name__ == "__main__":
+ app.run(host='0.0.0.0')
+```
+Initialize replit auth on your app by calling ```replit_auth(app)```, after creating your flask app. To get information, call ```request.user```, which will either return ```None``` or a ```dict``` with the information.
+# Replit Auth - Frontend
+```js
+var button = document.getElementById('login_with_replit');
+
+if (location.protocol !== 'https:') {
+ alert('Replit auth requires https!');
+}
+
+button.onclick = function() {
+ window.addEventListener('message', authComplete);
+
+ var h = 500;
+ var w = 350;
+ var left = (screen.width / 2) - ( w / 2);
+ var top = (screen.height / 2) - (h / 2);
+
+ var authWindow = window.open('https://replit.com/auth_with_repl_site?domain=' + location.host, '_blank', 'modal=yes, toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=' + w + ', height=' + h + ', top=' + top + ', left=' + left)
+
+ function authComplete(e) {
+ if (e.data !== 'auth_complete') {
+ return;
+ }
+
+ window.removeEventListener('message', authComplete);
+
+ authWindow.close();
+
+ // Reload the page to get the credentials.
+ location.reload();
+ }
+}
+```
+Usage:
+1. Apply the javascript code above to your website.
+2. Set the ```id``` of you login button to ```login_with_replit```.
+
+
+
+%prep
+%autosetup -n flask-replit-auth-1.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flask-replit-auth -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
+- Package Spec generated