summaryrefslogtreecommitdiff
path: root/python-flask-resty.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-resty.spec')
-rw-r--r--python-flask-resty.spec259
1 files changed, 259 insertions, 0 deletions
diff --git a/python-flask-resty.spec b/python-flask-resty.spec
new file mode 100644
index 0000000..7e0b03e
--- /dev/null
+++ b/python-flask-resty.spec
@@ -0,0 +1,259 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-RESTy
+Version: 4.0.2
+Release: 1
+Summary: Building blocks for REST APIs for Flask
+License: MIT
+URL: https://github.com/4Catalyzer/flask-resty
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/6a/c9f043e1d9b6f872e7056cdcc16dfffc58c2ea2e383056b50103aa86ae12/Flask-RESTy-4.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-Flask
+Requires: python3-Flask-SQLAlchemy
+Requires: python3-marshmallow
+Requires: python3-SQLAlchemy
+Requires: python3-Werkzeug
+Requires: python3-konch
+Requires: python3-sphinx
+Requires: python3-pallets-sphinx-themes
+Requires: python3-coverage
+Requires: python3-psycopg2-binary
+Requires: python3-pytest
+Requires: python3-tox
+Requires: python3-sphinx
+Requires: python3-pallets-sphinx-themes
+Requires: python3-PyJWT
+Requires: python3-cryptography
+Requires: python3-coverage
+Requires: python3-psycopg2-binary
+Requires: python3-pytest
+
+%description
+# Flask-RESTy [![Travis][build-badge]][build] [![Codecov][codecov-badge]][codecov] [![PyPI][pypi-badge]][pypi] [![marshmallow 3 compatible][marshmallow-badge]][marshmallow-upgrading]
+
+Flask-RESTy provides building blocks for creating REST APIs with [Flask](http://flask.pocoo.org/), [SQLAlchemy](https://www.sqlalchemy.org/), and [marshmallow](https://marshmallow.readthedocs.io/).
+
+```python
+from flask_resty import Api, GenericModelView
+
+from . import app, models, schemas
+
+
+class WidgetViewBase(GenericModelView):
+ model = models.Widget
+ schema = schemas.WidgetSchema()
+
+
+class WidgetListView(WidgetViewBase):
+ def get(self):
+ return self.list()
+
+ def post(self):
+ return self.create()
+
+
+class WidgetView(WidgetViewBase):
+ def get(self, id):
+ return self.retrieve(id)
+
+ def patch(self, id):
+ return self.update(id, partial=True)
+
+ def delete(self, id):
+ return self.destroy(id)
+
+
+api = Api(app, "/api")
+api.add_resource("/widgets", WidgetListView, WidgetView)
+```
+
+## Documentation
+
+Documentation is available at https://flask-resty.readthedocs.io/.
+
+## License
+
+MIT Licensed. See the bundled [LICENSE](https://github.com/4Catalyzer/flask-resty/blob/master/LICENSE) file for more details.
+
+[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty/master.svg
+[build]: https://travis-ci.org/4Catalyzer/flask-resty
+[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy.svg
+[pypi]: https://pypi.python.org/pypi/Flask-RESTy
+[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty/master.svg
+[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty
+[marshmallow-badge]: https://badgen.net/badge/marshmallow/3
+[marshmallow-upgrading]: https://marshmallow.readthedocs.io/en/latest/upgrading.html
+
+
+
+
+%package -n python3-Flask-RESTy
+Summary: Building blocks for REST APIs for Flask
+Provides: python-Flask-RESTy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-RESTy
+# Flask-RESTy [![Travis][build-badge]][build] [![Codecov][codecov-badge]][codecov] [![PyPI][pypi-badge]][pypi] [![marshmallow 3 compatible][marshmallow-badge]][marshmallow-upgrading]
+
+Flask-RESTy provides building blocks for creating REST APIs with [Flask](http://flask.pocoo.org/), [SQLAlchemy](https://www.sqlalchemy.org/), and [marshmallow](https://marshmallow.readthedocs.io/).
+
+```python
+from flask_resty import Api, GenericModelView
+
+from . import app, models, schemas
+
+
+class WidgetViewBase(GenericModelView):
+ model = models.Widget
+ schema = schemas.WidgetSchema()
+
+
+class WidgetListView(WidgetViewBase):
+ def get(self):
+ return self.list()
+
+ def post(self):
+ return self.create()
+
+
+class WidgetView(WidgetViewBase):
+ def get(self, id):
+ return self.retrieve(id)
+
+ def patch(self, id):
+ return self.update(id, partial=True)
+
+ def delete(self, id):
+ return self.destroy(id)
+
+
+api = Api(app, "/api")
+api.add_resource("/widgets", WidgetListView, WidgetView)
+```
+
+## Documentation
+
+Documentation is available at https://flask-resty.readthedocs.io/.
+
+## License
+
+MIT Licensed. See the bundled [LICENSE](https://github.com/4Catalyzer/flask-resty/blob/master/LICENSE) file for more details.
+
+[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty/master.svg
+[build]: https://travis-ci.org/4Catalyzer/flask-resty
+[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy.svg
+[pypi]: https://pypi.python.org/pypi/Flask-RESTy
+[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty/master.svg
+[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty
+[marshmallow-badge]: https://badgen.net/badge/marshmallow/3
+[marshmallow-upgrading]: https://marshmallow.readthedocs.io/en/latest/upgrading.html
+
+
+
+
+%package help
+Summary: Development documents and examples for Flask-RESTy
+Provides: python3-Flask-RESTy-doc
+%description help
+# Flask-RESTy [![Travis][build-badge]][build] [![Codecov][codecov-badge]][codecov] [![PyPI][pypi-badge]][pypi] [![marshmallow 3 compatible][marshmallow-badge]][marshmallow-upgrading]
+
+Flask-RESTy provides building blocks for creating REST APIs with [Flask](http://flask.pocoo.org/), [SQLAlchemy](https://www.sqlalchemy.org/), and [marshmallow](https://marshmallow.readthedocs.io/).
+
+```python
+from flask_resty import Api, GenericModelView
+
+from . import app, models, schemas
+
+
+class WidgetViewBase(GenericModelView):
+ model = models.Widget
+ schema = schemas.WidgetSchema()
+
+
+class WidgetListView(WidgetViewBase):
+ def get(self):
+ return self.list()
+
+ def post(self):
+ return self.create()
+
+
+class WidgetView(WidgetViewBase):
+ def get(self, id):
+ return self.retrieve(id)
+
+ def patch(self, id):
+ return self.update(id, partial=True)
+
+ def delete(self, id):
+ return self.destroy(id)
+
+
+api = Api(app, "/api")
+api.add_resource("/widgets", WidgetListView, WidgetView)
+```
+
+## Documentation
+
+Documentation is available at https://flask-resty.readthedocs.io/.
+
+## License
+
+MIT Licensed. See the bundled [LICENSE](https://github.com/4Catalyzer/flask-resty/blob/master/LICENSE) file for more details.
+
+[build-badge]: https://img.shields.io/travis/4Catalyzer/flask-resty/master.svg
+[build]: https://travis-ci.org/4Catalyzer/flask-resty
+[pypi-badge]: https://img.shields.io/pypi/v/Flask-RESTy.svg
+[pypi]: https://pypi.python.org/pypi/Flask-RESTy
+[codecov-badge]: https://img.shields.io/codecov/c/github/4Catalyzer/flask-resty/master.svg
+[codecov]: https://codecov.io/gh/4Catalyzer/flask-resty
+[marshmallow-badge]: https://badgen.net/badge/marshmallow/3
+[marshmallow-upgrading]: https://marshmallow.readthedocs.io/en/latest/upgrading.html
+
+
+
+
+%prep
+%autosetup -n Flask-RESTy-4.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-RESTy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.2-1
+- Package Spec generated