summaryrefslogtreecommitdiff
path: root/python-flask-wizard.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-wizard.spec')
-rw-r--r--python-flask-wizard.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-flask-wizard.spec b/python-flask-wizard.spec
new file mode 100644
index 0000000..4af61d4
--- /dev/null
+++ b/python-flask-wizard.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-Wizard
+Version: 0.5.28
+Release: 1
+Summary: Rapid and easy chatbot development in Python for multiple channels
+License: Apache 2.0
+URL: https://github.com/ozzai/flask-wizard
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/b5/b2e590a15836398ea096685d416600caf3d01a212a4b02878d676082603f/Flask-Wizard-0.5.28.tar.gz
+BuildArch: noarch
+
+
+%description
+Easy Bot development Framework for Flask
+
+%package -n python3-Flask-Wizard
+Summary: Rapid and easy chatbot development in Python for multiple channels
+Provides: python-Flask-Wizard
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-Wizard
+Easy Bot development Framework for Flask
+
+%package help
+Summary: Development documents and examples for Flask-Wizard
+Provides: python3-Flask-Wizard-doc
+%description help
+Easy Bot development Framework for Flask
+
+%prep
+%autosetup -n Flask-Wizard-0.5.28
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-Wizard -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.28-1
+- Package Spec generated