summaryrefslogtreecommitdiff
path: root/python-flexget.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flexget.spec')
-rw-r--r--python-flexget.spec160
1 files changed, 160 insertions, 0 deletions
diff --git a/python-flexget.spec b/python-flexget.spec
new file mode 100644
index 0000000..466bcf9
--- /dev/null
+++ b/python-flexget.spec
@@ -0,0 +1,160 @@
+%global _empty_manifest_terminate_build 0
+Name: python-FlexGet
+Version: 3.6.0
+Release: 1
+Summary: FlexGet is a program aimed to automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
+License: The MIT License Copyright (C) 2006, Riku 'Shrike' Lindblad Copyright (C) 2007, Marko Koivusalo Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+URL: https://flexget.com
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/27/a2/2bb8f760d09eab63ccaac31dbc05ab4a9d8a208b710e3ad3eaa20bebedbc/FlexGet-3.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-greenlet
+Requires: python3-importlib-metadata
+Requires: python3-zipp
+Requires: python3-backports-zoneinfo
+Requires: python3-importlib-resources
+Requires: python3-pkgutil-resolve-name
+Requires: python3-apscheduler
+Requires: python3-certifi
+Requires: python3-charset-normalizer
+Requires: python3-idna
+Requires: python3-pytz-deprecation-shim
+Requires: python3-pytz
+Requires: python3-requests
+Requires: python3-setuptools
+Requires: python3-six
+Requires: python3-tzdata
+Requires: python3-tzlocal
+Requires: python3-urllib3
+Requires: python3-aniso8601
+Requires: python3-attrs
+Requires: python3-autocommand
+Requires: python3-babelfish
+Requires: python3-beautifulsoup4
+Requires: python3-brotli
+Requires: python3-cheroot
+Requires: python3-cherrypy
+Requires: python3-click
+Requires: python3-colorama
+Requires: python3-commonmark
+Requires: python3-feedparser
+Requires: python3-flask-compress
+Requires: python3-flask-cors
+Requires: python3-flask-login
+Requires: python3-flask-restful
+Requires: python3-flask-restx
+Requires: python3-flask
+Requires: python3-guessit
+Requires: python3-html5lib
+Requires: python3-inflect
+Requires: python3-itsdangerous
+Requires: python3-jaraco-classes
+Requires: python3-jaraco-collections
+Requires: python3-jaraco-context
+Requires: python3-jaraco-functools
+Requires: python3-jaraco-text
+Requires: python3-jinja2
+Requires: python3-jsonschema
+Requires: python3-loguru
+Requires: python3-markupsafe
+Requires: python3-more-itertools
+Requires: python3-packaging
+Requires: python3-plumbum
+Requires: python3-portend
+Requires: python3-psutil
+Requires: python3-pydantic
+Requires: python3-pygments
+Requires: python3-pynzb
+Requires: python3-pyparsing
+Requires: python3-pyrsistent
+Requires: python3-pyrss2gen
+Requires: python3-dateutil
+Requires: python3-pyyaml
+Requires: python3-rebulk
+Requires: python3-rich
+Requires: python3-rpyc
+Requires: python3-sgmllib3k
+Requires: python3-soupsieve
+Requires: python3-sqlalchemy
+Requires: python3-tempora
+Requires: python3-typing-extensions
+Requires: python3-webencodings
+Requires: python3-werkzeug
+Requires: python3-zc-lockfile
+Requires: python3-zxcvbn-python
+Requires: python3-win32-setctime
+Requires: python3-pywin32
+
+%description
+ Commenting these out for now, as they seem to be broken.
+`FlexGet`_ is a multipurpose automation tool for content like torrents, nzbs,
+podcasts, comics, series, movies, etc. It can use different kinds of sources
+like RSS-feeds, html pages, csv files, search engines and there are even
+plugins for sites that do not provide any kind of useful feeds.
+
+%package -n python3-FlexGet
+Summary: FlexGet is a program aimed to automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
+Provides: python-FlexGet
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-FlexGet
+ Commenting these out for now, as they seem to be broken.
+`FlexGet`_ is a multipurpose automation tool for content like torrents, nzbs,
+podcasts, comics, series, movies, etc. It can use different kinds of sources
+like RSS-feeds, html pages, csv files, search engines and there are even
+plugins for sites that do not provide any kind of useful feeds.
+
+%package help
+Summary: Development documents and examples for FlexGet
+Provides: python3-FlexGet-doc
+%description help
+ Commenting these out for now, as they seem to be broken.
+`FlexGet`_ is a multipurpose automation tool for content like torrents, nzbs,
+podcasts, comics, series, movies, etc. It can use different kinds of sources
+like RSS-feeds, html pages, csv files, search engines and there are even
+plugins for sites that do not provide any kind of useful feeds.
+
+%prep
+%autosetup -n FlexGet-3.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-FlexGet -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.6.0-1
+- Package Spec generated