summaryrefslogtreecommitdiff
path: root/python-focal-loss.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-focal-loss.spec')
-rw-r--r--python-focal-loss.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-focal-loss.spec b/python-focal-loss.spec
new file mode 100644
index 0000000..b63f788
--- /dev/null
+++ b/python-focal-loss.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-focal-loss
+Version: 0.0.7
+Release: 1
+Summary: TensorFlow implementation of focal loss.
+License: Apache 2.0
+URL: https://github.com/artemmavrin/focal-loss
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/57/b0/6e7497f3526cd4dd27826308d6822c25ce1405f683b17c2f515dbffb4752/focal-loss-0.0.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-tensorflow
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-matplotlib
+Requires: python3-seaborn
+Requires: python3-pytest
+Requires: python3-coverage
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+
+%description
+
+
+%package -n python3-focal-loss
+Summary: TensorFlow implementation of focal loss.
+Provides: python-focal-loss
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-focal-loss
+
+
+%package help
+Summary: Development documents and examples for focal-loss
+Provides: python3-focal-loss-doc
+%description help
+
+
+%prep
+%autosetup -n focal-loss-0.0.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-focal-loss -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.7-1
+- Package Spec generated