summaryrefslogtreecommitdiff
path: root/python-forge.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-forge.spec')
-rw-r--r--python-forge.spec190
1 files changed, 190 insertions, 0 deletions
diff --git a/python-forge.spec b/python-forge.spec
new file mode 100644
index 0000000..1b6c5d0
--- /dev/null
+++ b/python-forge.spec
@@ -0,0 +1,190 @@
+%global _empty_manifest_terminate_build 0
+Name: python-forge
+Version: 0.22.0
+Release: 1
+Summary: Quickly build a professional web app using Django.
+License: MIT
+URL: https://www.forgepackages.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/83/4b/dd63af0b277ea95f8fb6336bd18f8e6fd357dea112635203c3a244d4d282/forge-0.22.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-forge-core
+Requires: python3-forge-heroku
+Requires: python3-forge-db
+Requires: python3-forge-tailwind
+Requires: python3-forge-work
+Requires: python3-Django
+Requires: python3-django-widget-tweaks
+Requires: python3-dj-database-url
+Requires: python3-whitenoise
+Requires: python3-dotenv
+Requires: python3-click
+Requires: python3-redis
+Requires: python3-hiredis
+Requires: python3-pytest
+Requires: python3-pytest-django
+Requires: python3-ipython
+Requires: python3-black
+Requires: python3-ruff
+Requires: python3-coverage
+
+%description
+# Forge
+
+<img height="100" width="100" src="https://user-images.githubusercontent.com/649496/176748343-3829aad8-4bcf-4c25-bb5d-6dc1f796fac0.png" align="right" />
+
+**Quickly build a professional web app using Django.**
+
+Forge is a set of packages and opinions for how to build with Django.
+It guides how you work,
+chooses what tools you use,
+and makes decisions so you don't have to.
+
+At it's core,
+Forge *is* Django.
+But we've taken a number of steps to make it even easier to build and deploy a production-ready app on day one.
+
+If you're an experienced Django user,
+you'll understand and (hopefully) agree with some of Forge's opinions.
+If you're new to Django or building web applications,
+we've simply removed questions that you might not even be aware of.
+
+Forge will get you from *zero to one* on a revenue-generating SaaS, internal business application, or hobby project.
+
+More details can be found on [forgepackages.com](https://www.forgepackages.com/).
+
+## Quickstart
+
+Start a new project in 5 minutes:
+
+```sh
+curl -sSL https://forgepackages.com/quickstart.py | python3 - my-project
+```
+
+[![Forge Django quickstart](https://user-images.githubusercontent.com/649496/173145833-e4f96a4c-efb6-4cc3-b118-184be1a007f1.png)](https://www.youtube.com/watch?v=wYMRxTGDmdU)
+
+
+%package -n python3-forge
+Summary: Quickly build a professional web app using Django.
+Provides: python-forge
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-forge
+# Forge
+
+<img height="100" width="100" src="https://user-images.githubusercontent.com/649496/176748343-3829aad8-4bcf-4c25-bb5d-6dc1f796fac0.png" align="right" />
+
+**Quickly build a professional web app using Django.**
+
+Forge is a set of packages and opinions for how to build with Django.
+It guides how you work,
+chooses what tools you use,
+and makes decisions so you don't have to.
+
+At it's core,
+Forge *is* Django.
+But we've taken a number of steps to make it even easier to build and deploy a production-ready app on day one.
+
+If you're an experienced Django user,
+you'll understand and (hopefully) agree with some of Forge's opinions.
+If you're new to Django or building web applications,
+we've simply removed questions that you might not even be aware of.
+
+Forge will get you from *zero to one* on a revenue-generating SaaS, internal business application, or hobby project.
+
+More details can be found on [forgepackages.com](https://www.forgepackages.com/).
+
+## Quickstart
+
+Start a new project in 5 minutes:
+
+```sh
+curl -sSL https://forgepackages.com/quickstart.py | python3 - my-project
+```
+
+[![Forge Django quickstart](https://user-images.githubusercontent.com/649496/173145833-e4f96a4c-efb6-4cc3-b118-184be1a007f1.png)](https://www.youtube.com/watch?v=wYMRxTGDmdU)
+
+
+%package help
+Summary: Development documents and examples for forge
+Provides: python3-forge-doc
+%description help
+# Forge
+
+<img height="100" width="100" src="https://user-images.githubusercontent.com/649496/176748343-3829aad8-4bcf-4c25-bb5d-6dc1f796fac0.png" align="right" />
+
+**Quickly build a professional web app using Django.**
+
+Forge is a set of packages and opinions for how to build with Django.
+It guides how you work,
+chooses what tools you use,
+and makes decisions so you don't have to.
+
+At it's core,
+Forge *is* Django.
+But we've taken a number of steps to make it even easier to build and deploy a production-ready app on day one.
+
+If you're an experienced Django user,
+you'll understand and (hopefully) agree with some of Forge's opinions.
+If you're new to Django or building web applications,
+we've simply removed questions that you might not even be aware of.
+
+Forge will get you from *zero to one* on a revenue-generating SaaS, internal business application, or hobby project.
+
+More details can be found on [forgepackages.com](https://www.forgepackages.com/).
+
+## Quickstart
+
+Start a new project in 5 minutes:
+
+```sh
+curl -sSL https://forgepackages.com/quickstart.py | python3 - my-project
+```
+
+[![Forge Django quickstart](https://user-images.githubusercontent.com/649496/173145833-e4f96a4c-efb6-4cc3-b118-184be1a007f1.png)](https://www.youtube.com/watch?v=wYMRxTGDmdU)
+
+
+%prep
+%autosetup -n forge-0.22.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-forge -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.22.0-1
+- Package Spec generated