summaryrefslogtreecommitdiff
path: root/python-freetakserver-ui.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-freetakserver-ui.spec')
-rw-r--r--python-freetakserver-ui.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-freetakserver-ui.spec b/python-freetakserver-ui.spec
new file mode 100644
index 0000000..e9d8095
--- /dev/null
+++ b/python-freetakserver-ui.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-FreeTAKServer-UI
+Version: 1.9.9.2
+Release: 1
+Summary: an optional UI for FreeTAKServer
+License: Eclipse License
+URL: https://github.com/FreeTAKTeam/FreeTakServer
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/98/79/e89e804805b9e436905d46cd30cc07548ff6b507c2d64a4d8f1f1caa78e9/FreeTAKServer-UI-1.9.9.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-flask
+Requires: python3-flask-login
+Requires: python3-flask-migrate
+Requires: python3-flask-wtf
+Requires: python3-flask-sqlalchemy
+Requires: python3-email-validator
+Requires: python3-gunicorn
+Requires: python3-decouple
+Requires: python3-sqlalchemy-utils
+
+%description
+
+
+%package -n python3-FreeTAKServer-UI
+Summary: an optional UI for FreeTAKServer
+Provides: python-FreeTAKServer-UI
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-FreeTAKServer-UI
+
+
+%package help
+Summary: Development documents and examples for FreeTAKServer-UI
+Provides: python3-FreeTAKServer-UI-doc
+%description help
+
+
+%prep
+%autosetup -n FreeTAKServer-UI-1.9.9.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-FreeTAKServer-UI -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.9.9.2-1
+- Package Spec generated