summaryrefslogtreecommitdiff
path: root/python-gammapy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gammapy.spec')
-rw-r--r--python-gammapy.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-gammapy.spec b/python-gammapy.spec
new file mode 100644
index 0000000..9831a79
--- /dev/null
+++ b/python-gammapy.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-gammapy
+Version: 1.1
+Release: 1
+Summary: A Python package for gamma-ray astronomy
+License: BSD 3-Clause
+URL: https://gammapy.org
+Source0: https://mirrors.aliyun.com/pypi/web/packages/32/1e/3bd3e8e0647e6c36e5718452151eb7b44a11e1f3e2c9a9b45d0aa4ed3d30/gammapy-1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+* Webpage: https://gammapy.org
+* Documentation: https://docs.gammapy.org
+* Code: https://github.com/gammapy/gammapy
+
+Gammapy is an open-source Python package for gamma-ray astronomy built on Numpy, Scipy and Astropy.
+It is the base library for the science analysis tools of the Cherenkov Telescope Array Observatory
+and can also be used to analyse data from existing gamma-ray telescopes.
+
+
+%package -n python3-gammapy
+Summary: A Python package for gamma-ray astronomy
+Provides: python-gammapy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-gammapy
+
+* Webpage: https://gammapy.org
+* Documentation: https://docs.gammapy.org
+* Code: https://github.com/gammapy/gammapy
+
+Gammapy is an open-source Python package for gamma-ray astronomy built on Numpy, Scipy and Astropy.
+It is the base library for the science analysis tools of the Cherenkov Telescope Array Observatory
+and can also be used to analyse data from existing gamma-ray telescopes.
+
+
+%package help
+Summary: Development documents and examples for gammapy
+Provides: python3-gammapy-doc
+%description help
+
+* Webpage: https://gammapy.org
+* Documentation: https://docs.gammapy.org
+* Code: https://github.com/gammapy/gammapy
+
+Gammapy is an open-source Python package for gamma-ray astronomy built on Numpy, Scipy and Astropy.
+It is the base library for the science analysis tools of the Cherenkov Telescope Array Observatory
+and can also be used to analyse data from existing gamma-ray telescopes.
+
+
+%prep
+%autosetup -n gammapy-1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-gammapy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1-1
+- Package Spec generated