summaryrefslogtreecommitdiff
path: root/python-gcloud-aio-pubsub.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gcloud-aio-pubsub.spec')
-rw-r--r--python-gcloud-aio-pubsub.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-gcloud-aio-pubsub.spec b/python-gcloud-aio-pubsub.spec
new file mode 100644
index 0000000..69ff9ce
--- /dev/null
+++ b/python-gcloud-aio-pubsub.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-gcloud-aio-pubsub
+Version: 5.4.0
+Release: 1
+Summary: Python Client for Google Cloud Pub/Sub
+License: MIT
+URL: https://github.com/talkiq/gcloud-aio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/25/86/f1e3c3437f08e4c3379b2a7770e4a1372c86c4314f64d1974e6d756668c7/gcloud_aio_pubsub-5.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-gcloud-aio-auth
+Requires: python3-prometheus-client
+Requires: python3-setuptools
+
+%description
+ This is a shared codebase for ``gcloud-aio-pubsub`` and
+ ``gcloud-rest-pubsub``
+|pypi| |pythons-aio| |pythons-rest|
+
+%package -n python3-gcloud-aio-pubsub
+Summary: Python Client for Google Cloud Pub/Sub
+Provides: python-gcloud-aio-pubsub
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-gcloud-aio-pubsub
+ This is a shared codebase for ``gcloud-aio-pubsub`` and
+ ``gcloud-rest-pubsub``
+|pypi| |pythons-aio| |pythons-rest|
+
+%package help
+Summary: Development documents and examples for gcloud-aio-pubsub
+Provides: python3-gcloud-aio-pubsub-doc
+%description help
+ This is a shared codebase for ``gcloud-aio-pubsub`` and
+ ``gcloud-rest-pubsub``
+|pypi| |pythons-aio| |pythons-rest|
+
+%prep
+%autosetup -n gcloud-aio-pubsub-5.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-gcloud-aio-pubsub -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 5.4.0-1
+- Package Spec generated