%global _empty_manifest_terminate_build 0 Name: python-generallibrary Version: 2.9.12 Release: 1 Summary: Random useful code categorized into modules. License: mit URL: https://github.com/ManderaGeneral/generallibrary Source0: https://mirrors.nju.edu.cn/pypi/web/packages/06/87/c53816f40c83a646c0a4a7acd6a7ce072d5cd23c9984adbf78cdddd9e914/generallibrary-2.9.12.tar.gz BuildArch: noarch Requires: python3-generalimport Requires: python3-packaging Requires: python3-pyperclip Requires: python3-pytz Requires: python3-dill Requires: python3-matplotlib Requires: python3-networkx Requires: python3-pandas Requires: python3-tabulate Requires: python3-pandas Requires: python3-tabulate %description

generallibrary

Random useful code categorized into modules.

Table of Contents

generallibrary
├─ Dependency Diagram for ManderaGeneral
├─ Installation showing dependencies
├─ Information
├─ Attributes
├─ Contributions
└─ Todo

Dependency Diagram for ManderaGeneral

```mermaid flowchart LR 1([library]) --> 4([packager]) 2([file]) --> 4([packager]) 1([library]) --> 2([file]) 0([import]) --> 1([library]) 0([import]) --> 2([file]) 1([library]) --> 3([vector]) click 0 "https://github.com/ManderaGeneral/generalimport" click 1 "https://github.com/ManderaGeneral/generallibrary" click 2 "https://github.com/ManderaGeneral/generalfile" click 3 "https://github.com/ManderaGeneral/generalvector" click 4 "https://github.com/ManderaGeneral/generalpackager" style 1 fill:#482 ```

Installation showing dependencies

| `pip install` | `generallibrary` | `generallibrary[table]` | `generallibrary[full]` | |:-------------------------------------------------------------------|:-------------------|:--------------------------|:-------------------------| | generalimport | ✔️ | ✔️ | ✔️ | | packaging | ✔️ | ✔️ | ✔️ | | pyperclip | ✔️ | ✔️ | ✔️ | | pytz | ✔️ | ✔️ | ✔️ | | dill | ✔️ | ✔️ | ✔️ | | matplotlib | ✔️ | ✔️ | ✔️ | | networkx | ✔️ | ✔️ | ✔️ | | pandas | ❌ | ✔️ | ✔️ | | tabulate | ❌ | ✔️ | ✔️ |

Information

| Package | Ver | Latest Release | Python | Platform | Cover | |:-------------------------------------------------------------------|:---------------------------------------------------|:----------------------|:-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|:----------------|:--------| | [generallibrary](https://github.com/ManderaGeneral/generallibrary) | [2.9.12](https://pypi.org/project/generallibrary/) | 2022-10-27 16:21 CEST | [3.8](https://www.python.org/downloads/release/python-380/), [3.9](https://www.python.org/downloads/release/python-390/), [3.10](https://www.python.org/downloads/release/python-3100/), [3.11](https://www.python.org/downloads/release/python-3110/) | Windows, Ubuntu | 93.3 % |

Attributes

Module: generallibrary
├─ Class: AutoInitBases
├─ Class: BoolStr
├─ Class: CallTable
│  ├─ Method: generate
│  ├─ Method: generate_with_args
│  ├─ Method: generate_with_funcs
│  ├─ Method: set_args
│  └─ Method: set_funcs
├─ Class: CodeLine
│  ├─ Method: get_lines
│  └─ Method: text
├─ Class: DataClass
│  ├─ Method: field_dict
│  └─ Method: field_values
├─ Class: Date
│  ├─ Method: get_timezone_obj
│  └─ Method: now
├─ Class: DecoContext
│  ├─ Method: after
│  └─ Method: before
├─ Class: EmptyContext
├─ Class: EnvVar
│  └─ Property: value
├─ Class: HierarchyStorer
├─ Class: Log
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: configure_file
│  ├─ Method: configure_stream
│  ├─ Method: critical
│  ├─ Method: debug
│  ├─ Method: error
│  ├─ Method: info
│  ├─ Method: is_root
│  ├─ Method: loggers
│  ├─ Method: recycle_clear
│  ├─ Method: recycle_clear_all
│  └─ Method: warning
├─ Class: Markdown
│  ├─ Method: add_code_lines
│  ├─ Method: add_lines
│  ├─ Method: add_list_lines
│  ├─ Method: add_pre_lines
│  ├─ Method: add_table_lines
│  ├─ Method: format_header
│  ├─ Method: get_all_lines
│  ├─ Method: get_section_lines
│  ├─ Method: get_tags_post
│  ├─ Method: link
│  ├─ Method: render
│  ├─ Method: update_collapsible
│  └─ Method: wrap_with_tags
├─ Class: NetworkDiagram
│  ├─ Method: get_spouse
│  └─ Method: get_spouses
├─ Class: ObjInfo
│  ├─ Class: ObjInfo
│  ├─ Method: add_node
│  ├─ Method: check_if_parent_eligible
│  ├─ Method: defined_by_parent
│  ├─ Method: disconnect
│  ├─ Method: doc
│  ├─ Method: file
│  ├─ Method: from_base
│  ├─ Method: from_builtin
│  ├─ Method: from_class
│  ├─ Method: from_instance
│  ├─ Method: from_module
│  ├─ Method: get_all
│  ├─ Method: get_child
│  ├─ Method: get_children
│  ├─ Method: get_connections
│  ├─ Method: get_definition_line
│  ├─ Method: get_index
│  ├─ Method: get_lines
│  ├─ Method: get_node
│  ├─ Method: get_nodes
│  ├─ Method: get_ordered
│  ├─ Method: get_ordered_index
│  ├─ Method: get_origin
│  ├─ Method: get_parent
│  ├─ Method: get_parents
│  ├─ Method: get_sibling
│  ├─ Method: get_siblings
│  ├─ Method: graph
│  ├─ Method: identifier
│  ├─ Method: internal
│  ├─ Method: is_class
│  ├─ Method: is_function
│  ├─ Method: is_instance
│  ├─ Method: is_method
│  ├─ Method: is_module
│  ├─ Method: is_property
│  ├─ Method: mermaid
│  ├─ Method: module
│  ├─ Method: print_link_to_obj
│  ├─ Method: private
│  ├─ Method: protected
│  ├─ Method: public
│  ├─ Method: remove_node
│  ├─ Method: set_index
│  ├─ Method: set_parent
│  ├─ Method: spawn_parents
│  ├─ Method: type
│  └─ Method: view
├─ Class: Operators
│  └─ Method: deco_define_comparisons
├─ Class: PythonVersion
│  └─ Property: version
├─ Class: Recycle
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: recycle_clear
│  └─ Method: recycle_clear_all
├─ Class: RedirectStdout
├─ Class: SigInfo
│  ├─ Method: call
│  ├─ Property: callableObject
│  ├─ Method: class_from_callable
│  ├─ Property: defaults
│  ├─ Method: getIndexFromName
│  ├─ Property: leadingArgNames
│  ├─ Property: names
│  ├─ Property: namesRequired
│  ├─ Property: namesWithoutDefaults
│  ├─ Property: namesWithoutPacked
│  ├─ Property: packedArgs
│  ├─ Property: packedArgsName
│  ├─ Property: packedKwargs
│  ├─ Property: packedKwargsName
│  ├─ Property: parameters
│  ├─ Property: positionalArgNames
│  ├─ Property: positionalOnlyArgNames
│  ├─ Property: positionalOnlyOppositeArgNames
│  ├─ Property: positionalOppositeArgNames
│  ├─ Property: positional_extra
│  ├─ Property: unpackedArgs
│  └─ Property: unpackedKwargs
├─ Class: SortedList
│  ├─ Method: add
│  └─ Method: remove
├─ Class: Storable
│  ├─ Method: copy_node
│  ├─ Method: load_node
│  └─ Method: save_node
├─ Class: Timer
│  ├─ Method: output_time
│  └─ Method: time
├─ Class: TreeDiagram
│  └─ Method: view
├─ Class: Ver
│  └─ Method: bump
├─ Class: VerInfo
│  ├─ Property: caseSensitive
│  ├─ Property: pathDelimiter
│  ├─ Property: pathRootHasColon
│  ├─ Property: pathRootIsDelimiter
│  ├─ Property: positionalArgument
│  ├─ Property: pythonAlpha
│  ├─ Property: pythonBeta
│  ├─ Property: pythonCandidate
│  ├─ Property: pythonFinal
│  ├─ Property: pythonMajor
│  ├─ Property: pythonMicro
│  ├─ Property: pythonMinor
│  ├─ Property: pythonReleaseKeyword
│  ├─ Property: pythonReleaseLevel
│  ├─ Property: pythonSerial
│  ├─ Property: pythonSerialString
│  ├─ Property: pythonString
│  └─ Property: pythonVersion
├─ Function: auto_deco
├─ Function: cache_clear
├─ Function: calculate
├─ Function: call_base_hooks
├─ Function: ceil
├─ Function: clamp
├─ Class: classproperty
├─ Function: clipboard_copy
├─ Function: clipboard_get
├─ Function: combine
├─ Function: comma_and_and
├─ Function: comma_and_or
├─ Function: confineTo
├─ Function: debug
├─ Function: deco_bound_defaults
├─ Function: deco_cache
├─ Function: deco_cast_parameters
├─ Function: deco_cast_to_self
├─ Function: deco_extend
├─ Function: deco_optional_suppress
├─ Function: deco_propagate_while
├─ Function: deco_require
├─ Function: defaults
├─ Function: depth
├─ Function: dict_insert
├─ Function: dir_appearance_order
├─ Function: doubleRectify
├─ Function: dumps
├─ Function: exclusive
├─ Function: extend_list_in_dict
├─ Function: flatten
├─ Function: floor
├─ Function: get
├─ Function: getBaseClassNames
├─ Function: getBaseClasses
├─ Function: get_attrs_from_bases
├─ Function: get_definition_line
├─ Function: get_free_index
├─ Function: get_index
├─ Function: get_items
├─ Function: get_launch_options
├─ Function: get_origin
├─ Function: get_rows
├─ Function: get_values
├─ Function: getsize
├─ Function: hasMethod
├─ Function: hook
├─ Function: inclusive
├─ Function: initBases
├─ Function: inrange
├─ Function: interconnect
├─ Function: is_iterable
├─ Function: iter_first_value
├─ Function: join_with_str
├─ Function: loads
├─ Function: match
├─ Function: pivot_list
├─ Function: plur_sing
├─ Function: print_link
├─ Function: print_link_to_obj
├─ Function: rectify
├─ Function: remove
├─ Function: remove_duplicates
├─ Function: replace
├─ Function: round_
├─ Function: sign
├─ Function: sleep
├─ Function: split_list
├─ Function: strToDynamicType
├─ Function: subtract_list
├─ Function: terminal
├─ Function: typeChecker
├─ Function: unique_obj_in_list
├─ Function: update_dict_in_dict
└─ Function: wrapper_transfer

Contributions

Issue-creation and discussions are most welcome! Pull requests are not wanted, please discuss with me before investing any time

Todo

| Module | Message | |:------------------------------------------------------------------------------------------------------------------------------|:---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------| | code.py | Make Log use __name__ from previous frame so it doesn't write to root. | | code.py | Use another delimiter than , in Log and make sure it can handle quotes. | | diagram.py | Shared dict for NetworkDiagram, resolve logic with multiple parents. | | test_time.py | Fix time casting to wrong day when past midnight. | | objinfo.py | Recycle ObjInfo. | | versions.py | Use Ver in each part of VerInfo. |
Generated 2022-10-27 16:21 CEST for commit a7989582.
%package -n python3-generallibrary Summary: Random useful code categorized into modules. Provides: python-generallibrary BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-generallibrary

generallibrary

Random useful code categorized into modules.

Table of Contents

generallibrary
├─ Dependency Diagram for ManderaGeneral
├─ Installation showing dependencies
├─ Information
├─ Attributes
├─ Contributions
└─ Todo

Dependency Diagram for ManderaGeneral

```mermaid flowchart LR 1([library]) --> 4([packager]) 2([file]) --> 4([packager]) 1([library]) --> 2([file]) 0([import]) --> 1([library]) 0([import]) --> 2([file]) 1([library]) --> 3([vector]) click 0 "https://github.com/ManderaGeneral/generalimport" click 1 "https://github.com/ManderaGeneral/generallibrary" click 2 "https://github.com/ManderaGeneral/generalfile" click 3 "https://github.com/ManderaGeneral/generalvector" click 4 "https://github.com/ManderaGeneral/generalpackager" style 1 fill:#482 ```

Installation showing dependencies

| `pip install` | `generallibrary` | `generallibrary[table]` | `generallibrary[full]` | |:-------------------------------------------------------------------|:-------------------|:--------------------------|:-------------------------| | generalimport | ✔️ | ✔️ | ✔️ | | packaging | ✔️ | ✔️ | ✔️ | | pyperclip | ✔️ | ✔️ | ✔️ | | pytz | ✔️ | ✔️ | ✔️ | | dill | ✔️ | ✔️ | ✔️ | | matplotlib | ✔️ | ✔️ | ✔️ | | networkx | ✔️ | ✔️ | ✔️ | | pandas | ❌ | ✔️ | ✔️ | | tabulate | ❌ | ✔️ | ✔️ |

Information

| Package | Ver | Latest Release | Python | Platform | Cover | |:-------------------------------------------------------------------|:---------------------------------------------------|:----------------------|:-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|:----------------|:--------| | [generallibrary](https://github.com/ManderaGeneral/generallibrary) | [2.9.12](https://pypi.org/project/generallibrary/) | 2022-10-27 16:21 CEST | [3.8](https://www.python.org/downloads/release/python-380/), [3.9](https://www.python.org/downloads/release/python-390/), [3.10](https://www.python.org/downloads/release/python-3100/), [3.11](https://www.python.org/downloads/release/python-3110/) | Windows, Ubuntu | 93.3 % |

Attributes

Module: generallibrary
├─ Class: AutoInitBases
├─ Class: BoolStr
├─ Class: CallTable
│  ├─ Method: generate
│  ├─ Method: generate_with_args
│  ├─ Method: generate_with_funcs
│  ├─ Method: set_args
│  └─ Method: set_funcs
├─ Class: CodeLine
│  ├─ Method: get_lines
│  └─ Method: text
├─ Class: DataClass
│  ├─ Method: field_dict
│  └─ Method: field_values
├─ Class: Date
│  ├─ Method: get_timezone_obj
│  └─ Method: now
├─ Class: DecoContext
│  ├─ Method: after
│  └─ Method: before
├─ Class: EmptyContext
├─ Class: EnvVar
│  └─ Property: value
├─ Class: HierarchyStorer
├─ Class: Log
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: configure_file
│  ├─ Method: configure_stream
│  ├─ Method: critical
│  ├─ Method: debug
│  ├─ Method: error
│  ├─ Method: info
│  ├─ Method: is_root
│  ├─ Method: loggers
│  ├─ Method: recycle_clear
│  ├─ Method: recycle_clear_all
│  └─ Method: warning
├─ Class: Markdown
│  ├─ Method: add_code_lines
│  ├─ Method: add_lines
│  ├─ Method: add_list_lines
│  ├─ Method: add_pre_lines
│  ├─ Method: add_table_lines
│  ├─ Method: format_header
│  ├─ Method: get_all_lines
│  ├─ Method: get_section_lines
│  ├─ Method: get_tags_post
│  ├─ Method: link
│  ├─ Method: render
│  ├─ Method: update_collapsible
│  └─ Method: wrap_with_tags
├─ Class: NetworkDiagram
│  ├─ Method: get_spouse
│  └─ Method: get_spouses
├─ Class: ObjInfo
│  ├─ Class: ObjInfo
│  ├─ Method: add_node
│  ├─ Method: check_if_parent_eligible
│  ├─ Method: defined_by_parent
│  ├─ Method: disconnect
│  ├─ Method: doc
│  ├─ Method: file
│  ├─ Method: from_base
│  ├─ Method: from_builtin
│  ├─ Method: from_class
│  ├─ Method: from_instance
│  ├─ Method: from_module
│  ├─ Method: get_all
│  ├─ Method: get_child
│  ├─ Method: get_children
│  ├─ Method: get_connections
│  ├─ Method: get_definition_line
│  ├─ Method: get_index
│  ├─ Method: get_lines
│  ├─ Method: get_node
│  ├─ Method: get_nodes
│  ├─ Method: get_ordered
│  ├─ Method: get_ordered_index
│  ├─ Method: get_origin
│  ├─ Method: get_parent
│  ├─ Method: get_parents
│  ├─ Method: get_sibling
│  ├─ Method: get_siblings
│  ├─ Method: graph
│  ├─ Method: identifier
│  ├─ Method: internal
│  ├─ Method: is_class
│  ├─ Method: is_function
│  ├─ Method: is_instance
│  ├─ Method: is_method
│  ├─ Method: is_module
│  ├─ Method: is_property
│  ├─ Method: mermaid
│  ├─ Method: module
│  ├─ Method: print_link_to_obj
│  ├─ Method: private
│  ├─ Method: protected
│  ├─ Method: public
│  ├─ Method: remove_node
│  ├─ Method: set_index
│  ├─ Method: set_parent
│  ├─ Method: spawn_parents
│  ├─ Method: type
│  └─ Method: view
├─ Class: Operators
│  └─ Method: deco_define_comparisons
├─ Class: PythonVersion
│  └─ Property: version
├─ Class: Recycle
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: recycle_clear
│  └─ Method: recycle_clear_all
├─ Class: RedirectStdout
├─ Class: SigInfo
│  ├─ Method: call
│  ├─ Property: callableObject
│  ├─ Method: class_from_callable
│  ├─ Property: defaults
│  ├─ Method: getIndexFromName
│  ├─ Property: leadingArgNames
│  ├─ Property: names
│  ├─ Property: namesRequired
│  ├─ Property: namesWithoutDefaults
│  ├─ Property: namesWithoutPacked
│  ├─ Property: packedArgs
│  ├─ Property: packedArgsName
│  ├─ Property: packedKwargs
│  ├─ Property: packedKwargsName
│  ├─ Property: parameters
│  ├─ Property: positionalArgNames
│  ├─ Property: positionalOnlyArgNames
│  ├─ Property: positionalOnlyOppositeArgNames
│  ├─ Property: positionalOppositeArgNames
│  ├─ Property: positional_extra
│  ├─ Property: unpackedArgs
│  └─ Property: unpackedKwargs
├─ Class: SortedList
│  ├─ Method: add
│  └─ Method: remove
├─ Class: Storable
│  ├─ Method: copy_node
│  ├─ Method: load_node
│  └─ Method: save_node
├─ Class: Timer
│  ├─ Method: output_time
│  └─ Method: time
├─ Class: TreeDiagram
│  └─ Method: view
├─ Class: Ver
│  └─ Method: bump
├─ Class: VerInfo
│  ├─ Property: caseSensitive
│  ├─ Property: pathDelimiter
│  ├─ Property: pathRootHasColon
│  ├─ Property: pathRootIsDelimiter
│  ├─ Property: positionalArgument
│  ├─ Property: pythonAlpha
│  ├─ Property: pythonBeta
│  ├─ Property: pythonCandidate
│  ├─ Property: pythonFinal
│  ├─ Property: pythonMajor
│  ├─ Property: pythonMicro
│  ├─ Property: pythonMinor
│  ├─ Property: pythonReleaseKeyword
│  ├─ Property: pythonReleaseLevel
│  ├─ Property: pythonSerial
│  ├─ Property: pythonSerialString
│  ├─ Property: pythonString
│  └─ Property: pythonVersion
├─ Function: auto_deco
├─ Function: cache_clear
├─ Function: calculate
├─ Function: call_base_hooks
├─ Function: ceil
├─ Function: clamp
├─ Class: classproperty
├─ Function: clipboard_copy
├─ Function: clipboard_get
├─ Function: combine
├─ Function: comma_and_and
├─ Function: comma_and_or
├─ Function: confineTo
├─ Function: debug
├─ Function: deco_bound_defaults
├─ Function: deco_cache
├─ Function: deco_cast_parameters
├─ Function: deco_cast_to_self
├─ Function: deco_extend
├─ Function: deco_optional_suppress
├─ Function: deco_propagate_while
├─ Function: deco_require
├─ Function: defaults
├─ Function: depth
├─ Function: dict_insert
├─ Function: dir_appearance_order
├─ Function: doubleRectify
├─ Function: dumps
├─ Function: exclusive
├─ Function: extend_list_in_dict
├─ Function: flatten
├─ Function: floor
├─ Function: get
├─ Function: getBaseClassNames
├─ Function: getBaseClasses
├─ Function: get_attrs_from_bases
├─ Function: get_definition_line
├─ Function: get_free_index
├─ Function: get_index
├─ Function: get_items
├─ Function: get_launch_options
├─ Function: get_origin
├─ Function: get_rows
├─ Function: get_values
├─ Function: getsize
├─ Function: hasMethod
├─ Function: hook
├─ Function: inclusive
├─ Function: initBases
├─ Function: inrange
├─ Function: interconnect
├─ Function: is_iterable
├─ Function: iter_first_value
├─ Function: join_with_str
├─ Function: loads
├─ Function: match
├─ Function: pivot_list
├─ Function: plur_sing
├─ Function: print_link
├─ Function: print_link_to_obj
├─ Function: rectify
├─ Function: remove
├─ Function: remove_duplicates
├─ Function: replace
├─ Function: round_
├─ Function: sign
├─ Function: sleep
├─ Function: split_list
├─ Function: strToDynamicType
├─ Function: subtract_list
├─ Function: terminal
├─ Function: typeChecker
├─ Function: unique_obj_in_list
├─ Function: update_dict_in_dict
└─ Function: wrapper_transfer

Contributions

Issue-creation and discussions are most welcome! Pull requests are not wanted, please discuss with me before investing any time

Todo

| Module | Message | |:------------------------------------------------------------------------------------------------------------------------------|:---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------| | code.py | Make Log use __name__ from previous frame so it doesn't write to root. | | code.py | Use another delimiter than , in Log and make sure it can handle quotes. | | diagram.py | Shared dict for NetworkDiagram, resolve logic with multiple parents. | | test_time.py | Fix time casting to wrong day when past midnight. | | objinfo.py | Recycle ObjInfo. | | versions.py | Use Ver in each part of VerInfo. |
Generated 2022-10-27 16:21 CEST for commit a7989582.
%package help Summary: Development documents and examples for generallibrary Provides: python3-generallibrary-doc %description help

generallibrary

Random useful code categorized into modules.

Table of Contents

generallibrary
├─ Dependency Diagram for ManderaGeneral
├─ Installation showing dependencies
├─ Information
├─ Attributes
├─ Contributions
└─ Todo

Dependency Diagram for ManderaGeneral

```mermaid flowchart LR 1([library]) --> 4([packager]) 2([file]) --> 4([packager]) 1([library]) --> 2([file]) 0([import]) --> 1([library]) 0([import]) --> 2([file]) 1([library]) --> 3([vector]) click 0 "https://github.com/ManderaGeneral/generalimport" click 1 "https://github.com/ManderaGeneral/generallibrary" click 2 "https://github.com/ManderaGeneral/generalfile" click 3 "https://github.com/ManderaGeneral/generalvector" click 4 "https://github.com/ManderaGeneral/generalpackager" style 1 fill:#482 ```

Installation showing dependencies

| `pip install` | `generallibrary` | `generallibrary[table]` | `generallibrary[full]` | |:-------------------------------------------------------------------|:-------------------|:--------------------------|:-------------------------| | generalimport | ✔️ | ✔️ | ✔️ | | packaging | ✔️ | ✔️ | ✔️ | | pyperclip | ✔️ | ✔️ | ✔️ | | pytz | ✔️ | ✔️ | ✔️ | | dill | ✔️ | ✔️ | ✔️ | | matplotlib | ✔️ | ✔️ | ✔️ | | networkx | ✔️ | ✔️ | ✔️ | | pandas | ❌ | ✔️ | ✔️ | | tabulate | ❌ | ✔️ | ✔️ |

Information

| Package | Ver | Latest Release | Python | Platform | Cover | |:-------------------------------------------------------------------|:---------------------------------------------------|:----------------------|:-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|:----------------|:--------| | [generallibrary](https://github.com/ManderaGeneral/generallibrary) | [2.9.12](https://pypi.org/project/generallibrary/) | 2022-10-27 16:21 CEST | [3.8](https://www.python.org/downloads/release/python-380/), [3.9](https://www.python.org/downloads/release/python-390/), [3.10](https://www.python.org/downloads/release/python-3100/), [3.11](https://www.python.org/downloads/release/python-3110/) | Windows, Ubuntu | 93.3 % |

Attributes

Module: generallibrary
├─ Class: AutoInitBases
├─ Class: BoolStr
├─ Class: CallTable
│  ├─ Method: generate
│  ├─ Method: generate_with_args
│  ├─ Method: generate_with_funcs
│  ├─ Method: set_args
│  └─ Method: set_funcs
├─ Class: CodeLine
│  ├─ Method: get_lines
│  └─ Method: text
├─ Class: DataClass
│  ├─ Method: field_dict
│  └─ Method: field_values
├─ Class: Date
│  ├─ Method: get_timezone_obj
│  └─ Method: now
├─ Class: DecoContext
│  ├─ Method: after
│  └─ Method: before
├─ Class: EmptyContext
├─ Class: EnvVar
│  └─ Property: value
├─ Class: HierarchyStorer
├─ Class: Log
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: configure_file
│  ├─ Method: configure_stream
│  ├─ Method: critical
│  ├─ Method: debug
│  ├─ Method: error
│  ├─ Method: info
│  ├─ Method: is_root
│  ├─ Method: loggers
│  ├─ Method: recycle_clear
│  ├─ Method: recycle_clear_all
│  └─ Method: warning
├─ Class: Markdown
│  ├─ Method: add_code_lines
│  ├─ Method: add_lines
│  ├─ Method: add_list_lines
│  ├─ Method: add_pre_lines
│  ├─ Method: add_table_lines
│  ├─ Method: format_header
│  ├─ Method: get_all_lines
│  ├─ Method: get_section_lines
│  ├─ Method: get_tags_post
│  ├─ Method: link
│  ├─ Method: render
│  ├─ Method: update_collapsible
│  └─ Method: wrap_with_tags
├─ Class: NetworkDiagram
│  ├─ Method: get_spouse
│  └─ Method: get_spouses
├─ Class: ObjInfo
│  ├─ Class: ObjInfo
│  ├─ Method: add_node
│  ├─ Method: check_if_parent_eligible
│  ├─ Method: defined_by_parent
│  ├─ Method: disconnect
│  ├─ Method: doc
│  ├─ Method: file
│  ├─ Method: from_base
│  ├─ Method: from_builtin
│  ├─ Method: from_class
│  ├─ Method: from_instance
│  ├─ Method: from_module
│  ├─ Method: get_all
│  ├─ Method: get_child
│  ├─ Method: get_children
│  ├─ Method: get_connections
│  ├─ Method: get_definition_line
│  ├─ Method: get_index
│  ├─ Method: get_lines
│  ├─ Method: get_node
│  ├─ Method: get_nodes
│  ├─ Method: get_ordered
│  ├─ Method: get_ordered_index
│  ├─ Method: get_origin
│  ├─ Method: get_parent
│  ├─ Method: get_parents
│  ├─ Method: get_sibling
│  ├─ Method: get_siblings
│  ├─ Method: graph
│  ├─ Method: identifier
│  ├─ Method: internal
│  ├─ Method: is_class
│  ├─ Method: is_function
│  ├─ Method: is_instance
│  ├─ Method: is_method
│  ├─ Method: is_module
│  ├─ Method: is_property
│  ├─ Method: mermaid
│  ├─ Method: module
│  ├─ Method: print_link_to_obj
│  ├─ Method: private
│  ├─ Method: protected
│  ├─ Method: public
│  ├─ Method: remove_node
│  ├─ Method: set_index
│  ├─ Method: set_parent
│  ├─ Method: spawn_parents
│  ├─ Method: type
│  └─ Method: view
├─ Class: Operators
│  └─ Method: deco_define_comparisons
├─ Class: PythonVersion
│  └─ Property: version
├─ Class: Recycle
│  ├─ Method: assert_max_one_missing_name
│  ├─ Method: recycle_clear
│  └─ Method: recycle_clear_all
├─ Class: RedirectStdout
├─ Class: SigInfo
│  ├─ Method: call
│  ├─ Property: callableObject
│  ├─ Method: class_from_callable
│  ├─ Property: defaults
│  ├─ Method: getIndexFromName
│  ├─ Property: leadingArgNames
│  ├─ Property: names
│  ├─ Property: namesRequired
│  ├─ Property: namesWithoutDefaults
│  ├─ Property: namesWithoutPacked
│  ├─ Property: packedArgs
│  ├─ Property: packedArgsName
│  ├─ Property: packedKwargs
│  ├─ Property: packedKwargsName
│  ├─ Property: parameters
│  ├─ Property: positionalArgNames
│  ├─ Property: positionalOnlyArgNames
│  ├─ Property: positionalOnlyOppositeArgNames
│  ├─ Property: positionalOppositeArgNames
│  ├─ Property: positional_extra
│  ├─ Property: unpackedArgs
│  └─ Property: unpackedKwargs
├─ Class: SortedList
│  ├─ Method: add
│  └─ Method: remove
├─ Class: Storable
│  ├─ Method: copy_node
│  ├─ Method: load_node
│  └─ Method: save_node
├─ Class: Timer
│  ├─ Method: output_time
│  └─ Method: time
├─ Class: TreeDiagram
│  └─ Method: view
├─ Class: Ver
│  └─ Method: bump
├─ Class: VerInfo
│  ├─ Property: caseSensitive
│  ├─ Property: pathDelimiter
│  ├─ Property: pathRootHasColon
│  ├─ Property: pathRootIsDelimiter
│  ├─ Property: positionalArgument
│  ├─ Property: pythonAlpha
│  ├─ Property: pythonBeta
│  ├─ Property: pythonCandidate
│  ├─ Property: pythonFinal
│  ├─ Property: pythonMajor
│  ├─ Property: pythonMicro
│  ├─ Property: pythonMinor
│  ├─ Property: pythonReleaseKeyword
│  ├─ Property: pythonReleaseLevel
│  ├─ Property: pythonSerial
│  ├─ Property: pythonSerialString
│  ├─ Property: pythonString
│  └─ Property: pythonVersion
├─ Function: auto_deco
├─ Function: cache_clear
├─ Function: calculate
├─ Function: call_base_hooks
├─ Function: ceil
├─ Function: clamp
├─ Class: classproperty
├─ Function: clipboard_copy
├─ Function: clipboard_get
├─ Function: combine
├─ Function: comma_and_and
├─ Function: comma_and_or
├─ Function: confineTo
├─ Function: debug
├─ Function: deco_bound_defaults
├─ Function: deco_cache
├─ Function: deco_cast_parameters
├─ Function: deco_cast_to_self
├─ Function: deco_extend
├─ Function: deco_optional_suppress
├─ Function: deco_propagate_while
├─ Function: deco_require
├─ Function: defaults
├─ Function: depth
├─ Function: dict_insert
├─ Function: dir_appearance_order
├─ Function: doubleRectify
├─ Function: dumps
├─ Function: exclusive
├─ Function: extend_list_in_dict
├─ Function: flatten
├─ Function: floor
├─ Function: get
├─ Function: getBaseClassNames
├─ Function: getBaseClasses
├─ Function: get_attrs_from_bases
├─ Function: get_definition_line
├─ Function: get_free_index
├─ Function: get_index
├─ Function: get_items
├─ Function: get_launch_options
├─ Function: get_origin
├─ Function: get_rows
├─ Function: get_values
├─ Function: getsize
├─ Function: hasMethod
├─ Function: hook
├─ Function: inclusive
├─ Function: initBases
├─ Function: inrange
├─ Function: interconnect
├─ Function: is_iterable
├─ Function: iter_first_value
├─ Function: join_with_str
├─ Function: loads
├─ Function: match
├─ Function: pivot_list
├─ Function: plur_sing
├─ Function: print_link
├─ Function: print_link_to_obj
├─ Function: rectify
├─ Function: remove
├─ Function: remove_duplicates
├─ Function: replace
├─ Function: round_
├─ Function: sign
├─ Function: sleep
├─ Function: split_list
├─ Function: strToDynamicType
├─ Function: subtract_list
├─ Function: terminal
├─ Function: typeChecker
├─ Function: unique_obj_in_list
├─ Function: update_dict_in_dict
└─ Function: wrapper_transfer

Contributions

Issue-creation and discussions are most welcome! Pull requests are not wanted, please discuss with me before investing any time

Todo

| Module | Message | |:------------------------------------------------------------------------------------------------------------------------------|:---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------| | code.py | Make Log use __name__ from previous frame so it doesn't write to root. | | code.py | Use another delimiter than , in Log and make sure it can handle quotes. | | diagram.py | Shared dict for NetworkDiagram, resolve logic with multiple parents. | | test_time.py | Fix time casting to wrong day when past midnight. | | objinfo.py | Recycle ObjInfo. | | versions.py | Use Ver in each part of VerInfo. |
Generated 2022-10-27 16:21 CEST for commit a7989582.
%prep %autosetup -n generallibrary-2.9.12 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-generallibrary -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 2.9.12-1 - Package Spec generated