summaryrefslogtreecommitdiff
path: root/python-geniverse.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-geniverse.spec')
-rw-r--r--python-geniverse.spec154
1 files changed, 154 insertions, 0 deletions
diff --git a/python-geniverse.spec b/python-geniverse.spec
new file mode 100644
index 0000000..f2193ae
--- /dev/null
+++ b/python-geniverse.spec
@@ -0,0 +1,154 @@
+%global _empty_manifest_terminate_build 0
+Name: python-geniverse
+Version: 0.1.10
+Release: 1
+Summary: Open-source library for guiding generative AI models.
+License: MIT License
+URL: https://github.com/thegeniverse/geniverse
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/12/0f/87b8a98e14cfd0118514c2d325f9c8e31a14d84e438524d6392e30de3796/geniverse-0.1.10.tar.gz
+BuildArch: noarch
+
+Requires: python3-geniverse-hub
+
+%description
+# The Geniverse API
+Open source library to access and utilize generative AI models.
+
+## Install
+```bash
+pip install geniverse
+```
+
+## Usage
+With this example we can generate `"a genierative universe"` using `VQGAN`. The result is a list of PIL images. Docs will be released soon :)
+```python
+from geniverse.models import TamingDecoder
+taming_decoder = TamingDecoder()
+image_list = taming_decoder.generate_from_prompt("a generative universe")
+```
+
+For now you can generate images from text prompts, interpolate and create infinite zooms with your results. More examples soon :)
+
+## Models
+
+So far we have adapted to our pipeline the following models:
+- VQGAN
+- Aphantasia
+- Mini-Dalle
+
+
+
+
+
+%package -n python3-geniverse
+Summary: Open-source library for guiding generative AI models.
+Provides: python-geniverse
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-geniverse
+# The Geniverse API
+Open source library to access and utilize generative AI models.
+
+## Install
+```bash
+pip install geniverse
+```
+
+## Usage
+With this example we can generate `"a genierative universe"` using `VQGAN`. The result is a list of PIL images. Docs will be released soon :)
+```python
+from geniverse.models import TamingDecoder
+taming_decoder = TamingDecoder()
+image_list = taming_decoder.generate_from_prompt("a generative universe")
+```
+
+For now you can generate images from text prompts, interpolate and create infinite zooms with your results. More examples soon :)
+
+## Models
+
+So far we have adapted to our pipeline the following models:
+- VQGAN
+- Aphantasia
+- Mini-Dalle
+
+
+
+
+
+%package help
+Summary: Development documents and examples for geniverse
+Provides: python3-geniverse-doc
+%description help
+# The Geniverse API
+Open source library to access and utilize generative AI models.
+
+## Install
+```bash
+pip install geniverse
+```
+
+## Usage
+With this example we can generate `"a genierative universe"` using `VQGAN`. The result is a list of PIL images. Docs will be released soon :)
+```python
+from geniverse.models import TamingDecoder
+taming_decoder = TamingDecoder()
+image_list = taming_decoder.generate_from_prompt("a generative universe")
+```
+
+For now you can generate images from text prompts, interpolate and create infinite zooms with your results. More examples soon :)
+
+## Models
+
+So far we have adapted to our pipeline the following models:
+- VQGAN
+- Aphantasia
+- Mini-Dalle
+
+
+
+
+
+%prep
+%autosetup -n geniverse-0.1.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-geniverse -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.10-1
+- Package Spec generated