summaryrefslogtreecommitdiff
path: root/python-genx3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-genx3.spec')
-rw-r--r--python-genx3.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-genx3.spec b/python-genx3.spec
new file mode 100644
index 0000000..e71fdd8
--- /dev/null
+++ b/python-genx3.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-genx3
+Version: 3.6.21
+Release: 1
+Summary: X-ray and Neutron reflectivity fitting software.
+License: GPL v3
+URL: http://genx.sourceforge.net/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/78/c89e1c0b9b1f0e079da53fd26a0bae5d57eb9b2d8205d43fdf10399f4d3d/genx3-3.6.21.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-scipy
+Requires: python3-appdirs
+Requires: python3-h5py
+Requires: python3-orsopy
+Requires: python3-wxpython
+Requires: python3-requests
+Requires: python3-docutils
+Requires: python3-numba
+Requires: python3-pint
+
+%description
+Tutorials can be found at: http://genx.sourceforge.net/doc/
+Examples can be found in the Menu Help->Examples.
+If you need more support send an e-mail to artur.glavic@psi.ch.
+
+%package -n python3-genx3
+Summary: X-ray and Neutron reflectivity fitting software.
+Provides: python-genx3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-genx3
+Tutorials can be found at: http://genx.sourceforge.net/doc/
+Examples can be found in the Menu Help->Examples.
+If you need more support send an e-mail to artur.glavic@psi.ch.
+
+%package help
+Summary: Development documents and examples for genx3
+Provides: python3-genx3-doc
+%description help
+Tutorials can be found at: http://genx.sourceforge.net/doc/
+Examples can be found in the Menu Help->Examples.
+If you need more support send an e-mail to artur.glavic@psi.ch.
+
+%prep
+%autosetup -n genx3-3.6.21
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-genx3 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.6.21-1
+- Package Spec generated