summaryrefslogtreecommitdiff
path: root/python-gestionatr.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gestionatr.spec')
-rw-r--r--python-gestionatr.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-gestionatr.spec b/python-gestionatr.spec
new file mode 100644
index 0000000..c789a2c
--- /dev/null
+++ b/python-gestionatr.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-gestionatr
+Version: 3.1.6
+Release: 1
+Summary: Llibreria de Gestió ATR
+License: General Public Licence 2
+URL: http://www.gisce.net
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/12/c4/c50408690f9329e8bbd7945194e7d93d089aa165936d87ec2b13e697a999/gestionatr-3.1.6.tar.gz
+BuildArch: noarch
+
+
+%description
+Long description
+
+%package -n python3-gestionatr
+Summary: Llibreria de Gestió ATR
+Provides: python-gestionatr
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-gestionatr
+Long description
+
+%package help
+Summary: Development documents and examples for gestionatr
+Provides: python3-gestionatr-doc
+%description help
+Long description
+
+%prep
+%autosetup -n gestionatr-3.1.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-gestionatr -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.6-1
+- Package Spec generated