summaryrefslogtreecommitdiff
path: root/python-ghalton.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:14:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:14:44 +0000
commit3e159c17274a19bb41730702ee71f8f7560126df (patch)
tree3bfecda5813120687f0aafd8223f1b16805a3698 /python-ghalton.spec
parent1db01afc2fdb3a73e15ea11b792a792a2ef5eeed (diff)
automatic import of python-ghalton
Diffstat (limited to 'python-ghalton.spec')
-rw-r--r--python-ghalton.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-ghalton.spec b/python-ghalton.spec
new file mode 100644
index 0000000..27526f9
--- /dev/null
+++ b/python-ghalton.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ghalton
+Version: 0.6.2
+Release: 1
+Summary: Generalized Halton number generator
+License: LICENSE.txt
+URL: https://github.com/fmder/ghalton
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e7/95/8869ba0de83e2b3aa30b40d4c1a4aaf8339f77130728523b8508aa581c27/ghalton-0.6.2.tar.gz
+
+
+%description
+Generalized Halton Number Generator
+
+
+
+
+%package -n python3-ghalton
+Summary: Generalized Halton number generator
+Provides: python-ghalton
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-ghalton
+Generalized Halton Number Generator
+
+
+
+
+%package help
+Summary: Development documents and examples for ghalton
+Provides: python3-ghalton-doc
+%description help
+Generalized Halton Number Generator
+
+
+
+
+%prep
+%autosetup -n ghalton-0.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ghalton -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.2-1
+- Package Spec generated