summaryrefslogtreecommitdiff
path: root/python-google-cloud-audit-log.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-google-cloud-audit-log.spec')
-rw-r--r--python-google-cloud-audit-log.spec98
1 files changed, 98 insertions, 0 deletions
diff --git a/python-google-cloud-audit-log.spec b/python-google-cloud-audit-log.spec
new file mode 100644
index 0000000..5b6b1ad
--- /dev/null
+++ b/python-google-cloud-audit-log.spec
@@ -0,0 +1,98 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-cloud-audit-log
+Version: 0.2.5
+Release: 1
+Summary: Google Cloud Audit Protos
+License: Apache-2.0
+URL: https://github.com/googleapis/python-audit-log
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b1/3d/48e8b2c0cc7113d1674526b609944ef77d7182f233b23c50fec7106b2e2c/google-cloud-audit-log-0.2.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-protobuf
+Requires: python3-googleapis-common-protos
+
+%description
+
+# Google APIs common protos
+
+[![pypi](https://img.shields.io/pypi/v/google-cloud-audit-log.svg)](https://pypi.org/project/google-cloud-audit-log/)
+
+
+The python classes generated from the `google/cloud/audit`
+protos in the [googleapis/googleapis](https://github.com/googleapis/googleapis/tree/master/google/cloud/audit) repository.
+
+
+%package -n python3-google-cloud-audit-log
+Summary: Google Cloud Audit Protos
+Provides: python-google-cloud-audit-log
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-cloud-audit-log
+
+# Google APIs common protos
+
+[![pypi](https://img.shields.io/pypi/v/google-cloud-audit-log.svg)](https://pypi.org/project/google-cloud-audit-log/)
+
+
+The python classes generated from the `google/cloud/audit`
+protos in the [googleapis/googleapis](https://github.com/googleapis/googleapis/tree/master/google/cloud/audit) repository.
+
+
+%package help
+Summary: Development documents and examples for google-cloud-audit-log
+Provides: python3-google-cloud-audit-log-doc
+%description help
+
+# Google APIs common protos
+
+[![pypi](https://img.shields.io/pypi/v/google-cloud-audit-log.svg)](https://pypi.org/project/google-cloud-audit-log/)
+
+
+The python classes generated from the `google/cloud/audit`
+protos in the [googleapis/googleapis](https://github.com/googleapis/googleapis/tree/master/google/cloud/audit) repository.
+
+
+%prep
+%autosetup -n google-cloud-audit-log-0.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-cloud-audit-log -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.5-1
+- Package Spec generated