summaryrefslogtreecommitdiff
path: root/python-google-cloud-dns.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-google-cloud-dns.spec')
-rw-r--r--python-google-cloud-dns.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-google-cloud-dns.spec b/python-google-cloud-dns.spec
new file mode 100644
index 0000000..0de7426
--- /dev/null
+++ b/python-google-cloud-dns.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-cloud-dns
+Version: 0.34.1
+Release: 1
+Summary: Google Cloud DNS API client library
+License: Apache 2.0
+URL: https://github.com/googleapis/python-dns
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f2/2e/59a39a34ed31e2d6237787dc5f0a0f33f0b429fd44a3473cad27aa725043/google-cloud-dns-0.34.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-google-cloud-core
+
+%description
+|preview| |pypi| |versions|
+`Cloud DNS API`_: provides methods that you can use to manage DNS for your applications.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package -n python3-google-cloud-dns
+Summary: Google Cloud DNS API client library
+Provides: python-google-cloud-dns
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-cloud-dns
+|preview| |pypi| |versions|
+`Cloud DNS API`_: provides methods that you can use to manage DNS for your applications.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package help
+Summary: Development documents and examples for google-cloud-dns
+Provides: python3-google-cloud-dns-doc
+%description help
+|preview| |pypi| |versions|
+`Cloud DNS API`_: provides methods that you can use to manage DNS for your applications.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%prep
+%autosetup -n google-cloud-dns-0.34.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-cloud-dns -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.34.1-1
+- Package Spec generated