summaryrefslogtreecommitdiff
path: root/python-google-cloud-runtimeconfig.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 18:14:35 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 18:14:35 +0000
commit2478707c0d2a6bdabe60d3c2d7b61496adcc83b6 (patch)
treee191c18c2251bd18696f43c67926b46cbe1e0522 /python-google-cloud-runtimeconfig.spec
parent101a9ec05b22b352666cd93508a70542fa0366dd (diff)
automatic import of python-google-cloud-runtimeconfig
Diffstat (limited to 'python-google-cloud-runtimeconfig.spec')
-rw-r--r--python-google-cloud-runtimeconfig.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-google-cloud-runtimeconfig.spec b/python-google-cloud-runtimeconfig.spec
new file mode 100644
index 0000000..92c6a22
--- /dev/null
+++ b/python-google-cloud-runtimeconfig.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-cloud-runtimeconfig
+Version: 0.33.2
+Release: 1
+Summary: Google Cloud RuntimeConfig API client library
+License: Apache 2.0
+URL: https://github.com/googleapis/python-runtimeconfig
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/4f/2826af5814aa5425a23299d0af1ecf4af6bb8bdefdb7451cd842c5871e61/google-cloud-runtimeconfig-0.33.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-google-cloud-core
+
+%description
+|preview| |pypi| |versions|
+`Google Cloud Runtime Configurator API`_:
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package -n python3-google-cloud-runtimeconfig
+Summary: Google Cloud RuntimeConfig API client library
+Provides: python-google-cloud-runtimeconfig
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-cloud-runtimeconfig
+|preview| |pypi| |versions|
+`Google Cloud Runtime Configurator API`_:
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package help
+Summary: Development documents and examples for google-cloud-runtimeconfig
+Provides: python3-google-cloud-runtimeconfig-doc
+%description help
+|preview| |pypi| |versions|
+`Google Cloud Runtime Configurator API`_:
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%prep
+%autosetup -n google-cloud-runtimeconfig-0.33.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-cloud-runtimeconfig -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.33.2-1
+- Package Spec generated