summaryrefslogtreecommitdiff
path: root/python-har2tree.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-har2tree.spec')
-rw-r--r--python-har2tree.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-har2tree.spec b/python-har2tree.spec
new file mode 100644
index 0000000..ad13f0c
--- /dev/null
+++ b/python-har2tree.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-har2tree
+Version: 1.19.3
+Release: 1
+Summary: HTTP Archive (HAR) to ETE Toolkit generator
+License: BSD-3-Clause
+URL: https://github.com/Lookyloo/har2tree
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bf/c9/980e66268a187b1b1064ef416edb75fa50a92e6db9dcac25db0450272c7b/har2tree-1.19.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-ete3
+Requires: python3-beautifulsoup4
+Requires: python3-lxml
+Requires: python3-six
+Requires: python3-publicsuffixlist
+Requires: python3-filetype
+Requires: python3-numpy
+Requires: python3-numpy
+Requires: python3-w3lib
+Requires: python3-Sphinx
+Requires: python3-charset-normalizer
+
+%description
+This package generate a tree out of a HAR dump.
+
+%package -n python3-har2tree
+Summary: HTTP Archive (HAR) to ETE Toolkit generator
+Provides: python-har2tree
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-har2tree
+This package generate a tree out of a HAR dump.
+
+%package help
+Summary: Development documents and examples for har2tree
+Provides: python3-har2tree-doc
+%description help
+This package generate a tree out of a HAR dump.
+
+%prep
+%autosetup -n har2tree-1.19.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-har2tree -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.19.3-1
+- Package Spec generated