summaryrefslogtreecommitdiff
path: root/python-haro.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 09:49:14 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 09:49:14 +0000
commit8efe35cef24624445a9068a5e93065a54886ca96 (patch)
treed01c6ff753e18a350a49b07011848d107f9f40f4 /python-haro.spec
parent2da454d6b5e61ee5971d7c03faf07c095b2472b4 (diff)
automatic import of python-haro
Diffstat (limited to 'python-haro.spec')
-rw-r--r--python-haro.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-haro.spec b/python-haro.spec
new file mode 100644
index 0000000..e098679
--- /dev/null
+++ b/python-haro.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-haro
+Version: 2018.11.15
+Release: 1
+Summary: Haro.ai Python Library
+License: Apache License Version 2.0, January 2004
+URL: https://github.com/empiricalresults/haro-python-sdk
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/52/c3/93019bac2ef1cc5d5920639f27ad716b74ca278c853c9c1a4c095ecd1eb1/haro-2018.11.15.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-requests
+
+%description
+A thin wrapper for making calls to Haro (https://haro.ai) events and prediction REST API's
+
+
+
+
+%package -n python3-haro
+Summary: Haro.ai Python Library
+Provides: python-haro
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-haro
+A thin wrapper for making calls to Haro (https://haro.ai) events and prediction REST API's
+
+
+
+
+%package help
+Summary: Development documents and examples for haro
+Provides: python3-haro-doc
+%description help
+A thin wrapper for making calls to Haro (https://haro.ai) events and prediction REST API's
+
+
+
+
+%prep
+%autosetup -n haro-2018.11.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-haro -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2018.11.15-1
+- Package Spec generated