summaryrefslogtreecommitdiff
path: root/python-helix-swarm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-helix-swarm.spec')
-rw-r--r--python-helix-swarm.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-helix-swarm.spec b/python-helix-swarm.spec
new file mode 100644
index 0000000..0e0980c
--- /dev/null
+++ b/python-helix-swarm.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-helix-swarm
+Version: 0.7.4
+Release: 1
+Summary: Python client for Perforce Helix Swarm (review board)
+License: MIT
+URL: https://github.com/pbelskiy/helix-swarm
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/85/d9/3a2bfb0bd97d9124decba07c5703f3d88e71219d7863c12138b162cbbbdd/helix-swarm-0.7.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-requests
+
+%description
+|Build status|
+|Docs status|
+|Coverage status|
+|Version status|
+|Downloads status 1|
+|Downloads status 2|
+ image:: https://github.com/pbelskiy/helix-swarm/workflows/Tests/badge.svg
+ image:: https://readthedocs.org/projects/helix-swarm/badge/?version=latest
+ image:: https://img.shields.io/coveralls/github/pbelskiy/helix-swarm?label=Coverage
+ image:: https://img.shields.io/pypi/pyversions/helix-swarm?label=Python
+ image:: https://img.shields.io/pypi/dm/helix-swarm?color=1&label=Downloads
+
+%package -n python3-helix-swarm
+Summary: Python client for Perforce Helix Swarm (review board)
+Provides: python-helix-swarm
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-helix-swarm
+|Build status|
+|Docs status|
+|Coverage status|
+|Version status|
+|Downloads status 1|
+|Downloads status 2|
+ image:: https://github.com/pbelskiy/helix-swarm/workflows/Tests/badge.svg
+ image:: https://readthedocs.org/projects/helix-swarm/badge/?version=latest
+ image:: https://img.shields.io/coveralls/github/pbelskiy/helix-swarm?label=Coverage
+ image:: https://img.shields.io/pypi/pyversions/helix-swarm?label=Python
+ image:: https://img.shields.io/pypi/dm/helix-swarm?color=1&label=Downloads
+
+%package help
+Summary: Development documents and examples for helix-swarm
+Provides: python3-helix-swarm-doc
+%description help
+|Build status|
+|Docs status|
+|Coverage status|
+|Version status|
+|Downloads status 1|
+|Downloads status 2|
+ image:: https://github.com/pbelskiy/helix-swarm/workflows/Tests/badge.svg
+ image:: https://readthedocs.org/projects/helix-swarm/badge/?version=latest
+ image:: https://img.shields.io/coveralls/github/pbelskiy/helix-swarm?label=Coverage
+ image:: https://img.shields.io/pypi/pyversions/helix-swarm?label=Python
+ image:: https://img.shields.io/pypi/dm/helix-swarm?color=1&label=Downloads
+
+%prep
+%autosetup -n helix-swarm-0.7.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-helix-swarm -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.4-1
+- Package Spec generated