summaryrefslogtreecommitdiff
path: root/python-horimote.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 07:03:12 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 07:03:12 +0000
commitdeef915eedb380ccc9e717378eadf9c34e8f9db8 (patch)
treeb104975fb51dffdc42755d42317349318341275e /python-horimote.spec
parentbf00fdb69ab221cb8a6219b13d974851d438ae04 (diff)
automatic import of python-horimote
Diffstat (limited to 'python-horimote.spec')
-rw-r--r--python-horimote.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-horimote.spec b/python-horimote.spec
new file mode 100644
index 0000000..1db31a2
--- /dev/null
+++ b/python-horimote.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-horimote
+Version: 0.4.1
+Release: 1
+Summary: Async API wrapper for Samsumgs set-top boxes SMT-G7400 and SMT-G7401.
+License: MIT
+URL: https://github.com/benleb/horimote
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7e/c9/53653eaa596939de4e14758fd63d62ae1b5e715a34abdd18ad46dfa68136/horimote-0.4.1.tar.gz
+BuildArch: noarch
+
+
+%description
+``` {.sourceCode .shell}
+$ pip install horimote
+```
+
+%package -n python3-horimote
+Summary: Async API wrapper for Samsumgs set-top boxes SMT-G7400 and SMT-G7401.
+Provides: python-horimote
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-horimote
+``` {.sourceCode .shell}
+$ pip install horimote
+```
+
+%package help
+Summary: Development documents and examples for horimote
+Provides: python3-horimote-doc
+%description help
+``` {.sourceCode .shell}
+$ pip install horimote
+```
+
+%prep
+%autosetup -n horimote-0.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-horimote -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
+- Package Spec generated