summaryrefslogtreecommitdiff
path: root/python-htmldate.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 20:12:38 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 20:12:38 +0000
commit2415dd52b92c0865cd246a91f2d43bcfffa8fe49 (patch)
tree0388a7cbd7f79c06b5baa3b561ddb08e1b80ed37 /python-htmldate.spec
parent83610e647178388bf27877a8b35988edb883717a (diff)
automatic import of python-htmldate
Diffstat (limited to 'python-htmldate.spec')
-rw-r--r--python-htmldate.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/python-htmldate.spec b/python-htmldate.spec
new file mode 100644
index 0000000..57c760f
--- /dev/null
+++ b/python-htmldate.spec
@@ -0,0 +1,91 @@
+%global _empty_manifest_terminate_build 0
+Name: python-htmldate
+Version: 1.4.2
+Release: 1
+Summary: Fast and robust extraction of original and updated publication dates from URLs and web pages.
+License: GPLv3+
+URL: https://htmldate.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6b/ae/cd69d6f951c0301f3d88693b289fa5695e0ebe2584905a4144c88c7151b0/htmldate-1.4.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-dateparser
+Requires: python3-lxml
+Requires: python3-dateutil
+Requires: python3-urllib3
+Requires: python3-backports-datetime-fromisoformat
+Requires: python3-charset-normalizer
+Requires: python3-charset-normalizer
+Requires: python3-urllib3[brotli]
+Requires: python3-cchardet
+Requires: python3-faust-cchardet
+Requires: python3-urllib3[brotli]
+Requires: python3-cchardet
+Requires: python3-faust-cchardet
+
+%description
+|
+|
+Find original and updated publication dates of any web page. From the command-line or within Python, all the steps needed from web page download to HTML parsing, scraping, and text analysis are included.
+
+%package -n python3-htmldate
+Summary: Fast and robust extraction of original and updated publication dates from URLs and web pages.
+Provides: python-htmldate
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-htmldate
+|
+|
+Find original and updated publication dates of any web page. From the command-line or within Python, all the steps needed from web page download to HTML parsing, scraping, and text analysis are included.
+
+%package help
+Summary: Development documents and examples for htmldate
+Provides: python3-htmldate-doc
+%description help
+|
+|
+Find original and updated publication dates of any web page. From the command-line or within Python, all the steps needed from web page download to HTML parsing, scraping, and text analysis are included.
+
+%prep
+%autosetup -n htmldate-1.4.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-htmldate -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.2-1
+- Package Spec generated