summaryrefslogtreecommitdiff
path: root/python-http-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-http-tools.spec')
-rw-r--r--python-http-tools.spec252
1 files changed, 252 insertions, 0 deletions
diff --git a/python-http-tools.spec b/python-http-tools.spec
new file mode 100644
index 0000000..33591f3
--- /dev/null
+++ b/python-http-tools.spec
@@ -0,0 +1,252 @@
+%global _empty_manifest_terminate_build 0
+Name: python-http-tools
+Version: 2.1.1
+Release: 1
+Summary: httptools helps you to capture, repeat and live intercept HTTP requests. It is built on top of [mitmproxy](https://mitmproxy.org/)
+License: GNU Lesser General Public License v3 or later (LGPLv3+)
+URL: https://github.com/MobSF/httptools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/91/13/650ee327e863df9a525b6e921624363e632806a215809a44507b1de85a6f/http-tools-2.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# httptools
+
+## capture | intercept | repeat
+httptools helps you to capture, repeat and live intercept HTTP requests with scripting capabilities and is built on top of [mitmproxy](https://mitmproxy.org/).
+
+Made with ![Love](https://cloud.githubusercontent.com/assets/4301109/16754758/82e3a63c-4813-11e6-9430-6015d98aeaab.png) in India
+
+[![PyPI version](https://badge.fury.io/py/http-tools.svg)](https://badge.fury.io/py/http-tools)
+[![License](https://img.shields.io/:license-lgpl3+-blue.svg)](https://www.gnu.org/licenses/lgpl-3.0.en.html)
+[![python](https://img.shields.io/badge/python-3.8+-blue.svg)](https://www.python.org/downloads/)
+[![http-tools](https://github.com/MobSF/httptools/workflows/http-tools/badge.svg?branch=master)](https://github.com/MobSF/httptools/actions)
+
+[![Requirements Status](https://requires.io/github/MobSF/httptools/requirements.svg?branch=master)](https://requires.io/github/MobSF/httptools/requirements/?branch=master)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:python)
+[![Language grade: JavaScript](https://img.shields.io/lgtm/grade/javascript/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:javascript)
+
+### Install
+
+```
+pip install http-tools
+```
+
+### Develop
+```
+$ git clone https://github.com/MobSF/httptools.git
+$ cd httptools
+$ python setup.py develop
+```
+
+### Usage
+
+```
+$ httptools
+usage: httptools [-h] [-m MODE] [-p PORT] [-i IP] [-n NAME] [-u UPSTREAM]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -m MODE, --mode MODE Supported modes
+ 1. capture: Capture requests.
+ 2. repeat: Repeat captured requests.
+ 3. intercept: Intercept and tamper the request.
+ 4. server: Start httptools server.
+ -p PORT, --port PORT Proxy Port
+ -i IP, --ip IP Proxy Host
+ -n NAME, --name NAME Project Name
+ -u UPSTREAM, --upstream UPSTREAM
+ Upstream Proxy
+```
+
+1. Capture - `httptools -m capture`
+ * Starts HTTPS proxy at `0.0.0.0:1337` by default.
+ * Install Root CA cert from `http://mitm.it/`
+2. Repeat - `httptools -m repeat`
+ * Replay the captured traffic. Use --upstream to forward it to
+ a fuzzer like BurpSuite or OWASP ZAP.
+3. Intercept - `httptools -m intercept`
+ * To Fiddle with HTTP request and response in live.
+ * Use: `http_tools/modules/interceptor.py` (The location will be relative to where httptools is installed)
+3. Server Web UI - `httptools -m server`
+ * Starts the Web UI at `https://0.0.0.0:1337` by default.
+
+
+%package -n python3-http-tools
+Summary: httptools helps you to capture, repeat and live intercept HTTP requests. It is built on top of [mitmproxy](https://mitmproxy.org/)
+Provides: python-http-tools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-http-tools
+# httptools
+
+## capture | intercept | repeat
+httptools helps you to capture, repeat and live intercept HTTP requests with scripting capabilities and is built on top of [mitmproxy](https://mitmproxy.org/).
+
+Made with ![Love](https://cloud.githubusercontent.com/assets/4301109/16754758/82e3a63c-4813-11e6-9430-6015d98aeaab.png) in India
+
+[![PyPI version](https://badge.fury.io/py/http-tools.svg)](https://badge.fury.io/py/http-tools)
+[![License](https://img.shields.io/:license-lgpl3+-blue.svg)](https://www.gnu.org/licenses/lgpl-3.0.en.html)
+[![python](https://img.shields.io/badge/python-3.8+-blue.svg)](https://www.python.org/downloads/)
+[![http-tools](https://github.com/MobSF/httptools/workflows/http-tools/badge.svg?branch=master)](https://github.com/MobSF/httptools/actions)
+
+[![Requirements Status](https://requires.io/github/MobSF/httptools/requirements.svg?branch=master)](https://requires.io/github/MobSF/httptools/requirements/?branch=master)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:python)
+[![Language grade: JavaScript](https://img.shields.io/lgtm/grade/javascript/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:javascript)
+
+### Install
+
+```
+pip install http-tools
+```
+
+### Develop
+```
+$ git clone https://github.com/MobSF/httptools.git
+$ cd httptools
+$ python setup.py develop
+```
+
+### Usage
+
+```
+$ httptools
+usage: httptools [-h] [-m MODE] [-p PORT] [-i IP] [-n NAME] [-u UPSTREAM]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -m MODE, --mode MODE Supported modes
+ 1. capture: Capture requests.
+ 2. repeat: Repeat captured requests.
+ 3. intercept: Intercept and tamper the request.
+ 4. server: Start httptools server.
+ -p PORT, --port PORT Proxy Port
+ -i IP, --ip IP Proxy Host
+ -n NAME, --name NAME Project Name
+ -u UPSTREAM, --upstream UPSTREAM
+ Upstream Proxy
+```
+
+1. Capture - `httptools -m capture`
+ * Starts HTTPS proxy at `0.0.0.0:1337` by default.
+ * Install Root CA cert from `http://mitm.it/`
+2. Repeat - `httptools -m repeat`
+ * Replay the captured traffic. Use --upstream to forward it to
+ a fuzzer like BurpSuite or OWASP ZAP.
+3. Intercept - `httptools -m intercept`
+ * To Fiddle with HTTP request and response in live.
+ * Use: `http_tools/modules/interceptor.py` (The location will be relative to where httptools is installed)
+3. Server Web UI - `httptools -m server`
+ * Starts the Web UI at `https://0.0.0.0:1337` by default.
+
+
+%package help
+Summary: Development documents and examples for http-tools
+Provides: python3-http-tools-doc
+%description help
+# httptools
+
+## capture | intercept | repeat
+httptools helps you to capture, repeat and live intercept HTTP requests with scripting capabilities and is built on top of [mitmproxy](https://mitmproxy.org/).
+
+Made with ![Love](https://cloud.githubusercontent.com/assets/4301109/16754758/82e3a63c-4813-11e6-9430-6015d98aeaab.png) in India
+
+[![PyPI version](https://badge.fury.io/py/http-tools.svg)](https://badge.fury.io/py/http-tools)
+[![License](https://img.shields.io/:license-lgpl3+-blue.svg)](https://www.gnu.org/licenses/lgpl-3.0.en.html)
+[![python](https://img.shields.io/badge/python-3.8+-blue.svg)](https://www.python.org/downloads/)
+[![http-tools](https://github.com/MobSF/httptools/workflows/http-tools/badge.svg?branch=master)](https://github.com/MobSF/httptools/actions)
+
+[![Requirements Status](https://requires.io/github/MobSF/httptools/requirements.svg?branch=master)](https://requires.io/github/MobSF/httptools/requirements/?branch=master)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:python)
+[![Language grade: JavaScript](https://img.shields.io/lgtm/grade/javascript/g/MobSF/httptools.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/MobSF/httptools/context:javascript)
+
+### Install
+
+```
+pip install http-tools
+```
+
+### Develop
+```
+$ git clone https://github.com/MobSF/httptools.git
+$ cd httptools
+$ python setup.py develop
+```
+
+### Usage
+
+```
+$ httptools
+usage: httptools [-h] [-m MODE] [-p PORT] [-i IP] [-n NAME] [-u UPSTREAM]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -m MODE, --mode MODE Supported modes
+ 1. capture: Capture requests.
+ 2. repeat: Repeat captured requests.
+ 3. intercept: Intercept and tamper the request.
+ 4. server: Start httptools server.
+ -p PORT, --port PORT Proxy Port
+ -i IP, --ip IP Proxy Host
+ -n NAME, --name NAME Project Name
+ -u UPSTREAM, --upstream UPSTREAM
+ Upstream Proxy
+```
+
+1. Capture - `httptools -m capture`
+ * Starts HTTPS proxy at `0.0.0.0:1337` by default.
+ * Install Root CA cert from `http://mitm.it/`
+2. Repeat - `httptools -m repeat`
+ * Replay the captured traffic. Use --upstream to forward it to
+ a fuzzer like BurpSuite or OWASP ZAP.
+3. Intercept - `httptools -m intercept`
+ * To Fiddle with HTTP request and response in live.
+ * Use: `http_tools/modules/interceptor.py` (The location will be relative to where httptools is installed)
+3. Server Web UI - `httptools -m server`
+ * Starts the Web UI at `https://0.0.0.0:1337` by default.
+
+
+%prep
+%autosetup -n http-tools-2.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-http-tools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
+- Package Spec generated