summaryrefslogtreecommitdiff
path: root/python-http.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 02:41:47 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 02:41:47 +0000
commitb3a1551608c2cdccf883cb89e2fafd644b96c980 (patch)
treeb9e96e1dc1fce2f19c9018be474e621525e10d39 /python-http.spec
parent0791967e4d2e38f7c76591ed35d4acf7d6c7b29d (diff)
automatic import of python-http
Diffstat (limited to 'python-http.spec')
-rw-r--r--python-http.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-http.spec b/python-http.spec
new file mode 100644
index 0000000..7d20810
--- /dev/null
+++ b/python-http.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-http
+Version: 0.02
+Release: 1
+Summary: HTTP library for Python
+License: MIT
+URL: https://github.com/franckcuny/http
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e3/91/a9260805e532e33df273b8f7dffad5c51693f8f9ba5f86bedcf42a7f22eb/http-0.02.tar.gz
+BuildArch: noarch
+
+
+%description
+http is heavily inspired by the `HTTP::Message <https://metacpan.org/module/HTTP::Message>`__ distribution.
+
+%package -n python3-http
+Summary: HTTP library for Python
+Provides: python-http
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-http
+http is heavily inspired by the `HTTP::Message <https://metacpan.org/module/HTTP::Message>`__ distribution.
+
+%package help
+Summary: Development documents and examples for http
+Provides: python3-http-doc
+%description help
+http is heavily inspired by the `HTTP::Message <https://metacpan.org/module/HTTP::Message>`__ distribution.
+
+%prep
+%autosetup -n http-0.02
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-http -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.02-1
+- Package Spec generated