summaryrefslogtreecommitdiff
path: root/python-httpie-jwt-auth.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 09:55:47 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 09:55:47 +0000
commit7216980f71f8878fdbe613e2644bf9aaf85e4e76 (patch)
tree2f630f801005b92f70b633000c2359cefd38088e /python-httpie-jwt-auth.spec
parente2b7245c7a76477e4fa0d200d85614556d7d5ac4 (diff)
automatic import of python-httpie-jwt-auth
Diffstat (limited to 'python-httpie-jwt-auth.spec')
-rw-r--r--python-httpie-jwt-auth.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-httpie-jwt-auth.spec b/python-httpie-jwt-auth.spec
new file mode 100644
index 0000000..e43853a
--- /dev/null
+++ b/python-httpie-jwt-auth.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-httpie-jwt-auth
+Version: 0.4.0
+Release: 1
+Summary: JWTAuth plugin for HTTPie.
+License: BSD
+URL: https://github.com/teracyhq/httpie-jwt-auth
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/f8/8a7c5169c042e83d1fc22bc3cdafe993e5b94e0c0918cb9ebd6fcce2269c/httpie-jwt-auth-0.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-httpie
+
+%description
+`JWTAuth (JSON Web Tokens) <https://github.com/teracyhq/httpie-jwt-auth>`_ auth plugin for
+`HTTPie <https://github.com/jkbr/httpie>`_.
+
+%package -n python3-httpie-jwt-auth
+Summary: JWTAuth plugin for HTTPie.
+Provides: python-httpie-jwt-auth
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-httpie-jwt-auth
+`JWTAuth (JSON Web Tokens) <https://github.com/teracyhq/httpie-jwt-auth>`_ auth plugin for
+`HTTPie <https://github.com/jkbr/httpie>`_.
+
+%package help
+Summary: Development documents and examples for httpie-jwt-auth
+Provides: python3-httpie-jwt-auth-doc
+%description help
+`JWTAuth (JSON Web Tokens) <https://github.com/teracyhq/httpie-jwt-auth>`_ auth plugin for
+`HTTPie <https://github.com/jkbr/httpie>`_.
+
+%prep
+%autosetup -n httpie-jwt-auth-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-httpie-jwt-auth -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated