summaryrefslogtreecommitdiff
path: root/python-imagesize.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 08:44:46 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 08:44:46 +0000
commite2a9752d62364be7365628995624e4f2ad15dd25 (patch)
tree1fe02a77dc50fb2bb0b4543642b2f8d2219df525 /python-imagesize.spec
parent5afad65e79938b181ad171b21b64da4d11577c15 (diff)
automatic import of python-imagesize
Diffstat (limited to 'python-imagesize.spec')
-rw-r--r--python-imagesize.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/python-imagesize.spec b/python-imagesize.spec
new file mode 100644
index 0000000..60ff6a9
--- /dev/null
+++ b/python-imagesize.spec
@@ -0,0 +1,117 @@
+%global _empty_manifest_terminate_build 0
+Name: python-imagesize
+Version: 1.4.1
+Release: 1
+Summary: Getting image size from png/jpeg/jpeg2000/gif file
+License: MIT
+URL: https://github.com/shibukawa/imagesize_py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a7/84/62473fb57d61e31fef6e36d64a179c8781605429fd927b5dd608c997be31/imagesize-1.4.1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+It parses image files' header and return image size.
+
+* PNG
+* JPEG
+* JPEG2000
+* GIF
+* TIFF
+* SVG
+* Netpbm
+* WebP
+
+This is a pure Python library.
+
+
+
+
+%package -n python3-imagesize
+Summary: Getting image size from png/jpeg/jpeg2000/gif file
+Provides: python-imagesize
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-imagesize
+
+It parses image files' header and return image size.
+
+* PNG
+* JPEG
+* JPEG2000
+* GIF
+* TIFF
+* SVG
+* Netpbm
+* WebP
+
+This is a pure Python library.
+
+
+
+
+%package help
+Summary: Development documents and examples for imagesize
+Provides: python3-imagesize-doc
+%description help
+
+It parses image files' header and return image size.
+
+* PNG
+* JPEG
+* JPEG2000
+* GIF
+* TIFF
+* SVG
+* Netpbm
+* WebP
+
+This is a pure Python library.
+
+
+
+
+%prep
+%autosetup -n imagesize-1.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-imagesize -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.1-1
+- Package Spec generated