summaryrefslogtreecommitdiff
path: root/python-indexed-zstd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-indexed-zstd.spec')
-rw-r--r--python-indexed-zstd.spec182
1 files changed, 182 insertions, 0 deletions
diff --git a/python-indexed-zstd.spec b/python-indexed-zstd.spec
new file mode 100644
index 0000000..fd7bf23
--- /dev/null
+++ b/python-indexed-zstd.spec
@@ -0,0 +1,182 @@
+%global _empty_manifest_terminate_build 0
+Name: python-indexed-zstd
+Version: 1.6.0
+Release: 1
+Summary: Fast random access to zstd files
+License: MIT
+URL: https://github.com/martinellimarco/indexed_zstd
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/90/38/fb4db668c97832a4532ff810e630306b59b30a487d7169ee3c28d7ad6a78/indexed_zstd-1.6.0.tar.gz
+
+
+%description
+[![PyPI version](https://badge.fury.io/py/indexed-zstd.svg)](https://badge.fury.io/py/indexed-zstd)
+[![Conda (channel only)](https://img.shields.io/conda/vn/conda-forge/indexed_zstd?label=conda)](https://anaconda.org/conda-forge/indexed_zstd)
+[![Python Version](https://img.shields.io/pypi/pyversions/indexed_zstd)](https://pypi.org/project/indexed-zstd/)
+[![PyPI Platforms](https://img.shields.io/badge/pypi-linux%20%7C%20macOSs-brightgreen)](https://pypi.org/project/indexed-zstd/)
+[![Downloads](https://pepy.tech/badge/indexed-zstd/month)](https://pepy.tech/project/indexed-zstd)
+[![License](https://img.shields.io/badge/license-MIT-blue.svg)](http://opensource.org/licenses/MIT)
+[![Build Status](https://github.com/martinellimarco/indexed_zstd/workflows/tests/badge.svg)](https://github.com/martinellimarco/indexed_zstd/actions)
+![C++17](https://img.shields.io/badge/C++-17-blue.svg)
+[![AUR version](https://img.shields.io/aur/version/python-indexed-zstd)](https://aur.archlinux.org/packages/python-indexed-zstd/)
+
+# indexed_zstd
+
+This module provides an IndexedZstdFile class, which can be used to seek inside zstd files without having to decompress them first.
+
+It's shamelessy based on [indexed_bzip2](https://github.com/mxmlnkn/indexed_bzip2), which was refactored to support [zstd](https://github.com/facebook/zstd) instead of bzip2 using [libzstd-seek](https://github.com/martinellimarco/libzstd-seek).
+
+Kudos to the author for its work.
+
+Seeking inside a block is only emulated, so IndexedZstdFile will only speed up seeking when there are more than one block.
+
+To create multi-block archives you may use [t2sz](https://github.com/martinellimarco/t2sz/).
+
+
+# Usage
+
+## Example 1
+
+```python3
+from indexed_zstd import IndexedZstdFile
+
+file = IndexedZstdFile( "example.zst" )
+
+# You can now use it like a normal file
+file.seek( 123 )
+data = file.read( 100 )
+```
+
+
+%package -n python3-indexed-zstd
+Summary: Fast random access to zstd files
+Provides: python-indexed-zstd
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-indexed-zstd
+[![PyPI version](https://badge.fury.io/py/indexed-zstd.svg)](https://badge.fury.io/py/indexed-zstd)
+[![Conda (channel only)](https://img.shields.io/conda/vn/conda-forge/indexed_zstd?label=conda)](https://anaconda.org/conda-forge/indexed_zstd)
+[![Python Version](https://img.shields.io/pypi/pyversions/indexed_zstd)](https://pypi.org/project/indexed-zstd/)
+[![PyPI Platforms](https://img.shields.io/badge/pypi-linux%20%7C%20macOSs-brightgreen)](https://pypi.org/project/indexed-zstd/)
+[![Downloads](https://pepy.tech/badge/indexed-zstd/month)](https://pepy.tech/project/indexed-zstd)
+[![License](https://img.shields.io/badge/license-MIT-blue.svg)](http://opensource.org/licenses/MIT)
+[![Build Status](https://github.com/martinellimarco/indexed_zstd/workflows/tests/badge.svg)](https://github.com/martinellimarco/indexed_zstd/actions)
+![C++17](https://img.shields.io/badge/C++-17-blue.svg)
+[![AUR version](https://img.shields.io/aur/version/python-indexed-zstd)](https://aur.archlinux.org/packages/python-indexed-zstd/)
+
+# indexed_zstd
+
+This module provides an IndexedZstdFile class, which can be used to seek inside zstd files without having to decompress them first.
+
+It's shamelessy based on [indexed_bzip2](https://github.com/mxmlnkn/indexed_bzip2), which was refactored to support [zstd](https://github.com/facebook/zstd) instead of bzip2 using [libzstd-seek](https://github.com/martinellimarco/libzstd-seek).
+
+Kudos to the author for its work.
+
+Seeking inside a block is only emulated, so IndexedZstdFile will only speed up seeking when there are more than one block.
+
+To create multi-block archives you may use [t2sz](https://github.com/martinellimarco/t2sz/).
+
+
+# Usage
+
+## Example 1
+
+```python3
+from indexed_zstd import IndexedZstdFile
+
+file = IndexedZstdFile( "example.zst" )
+
+# You can now use it like a normal file
+file.seek( 123 )
+data = file.read( 100 )
+```
+
+
+%package help
+Summary: Development documents and examples for indexed-zstd
+Provides: python3-indexed-zstd-doc
+%description help
+[![PyPI version](https://badge.fury.io/py/indexed-zstd.svg)](https://badge.fury.io/py/indexed-zstd)
+[![Conda (channel only)](https://img.shields.io/conda/vn/conda-forge/indexed_zstd?label=conda)](https://anaconda.org/conda-forge/indexed_zstd)
+[![Python Version](https://img.shields.io/pypi/pyversions/indexed_zstd)](https://pypi.org/project/indexed-zstd/)
+[![PyPI Platforms](https://img.shields.io/badge/pypi-linux%20%7C%20macOSs-brightgreen)](https://pypi.org/project/indexed-zstd/)
+[![Downloads](https://pepy.tech/badge/indexed-zstd/month)](https://pepy.tech/project/indexed-zstd)
+[![License](https://img.shields.io/badge/license-MIT-blue.svg)](http://opensource.org/licenses/MIT)
+[![Build Status](https://github.com/martinellimarco/indexed_zstd/workflows/tests/badge.svg)](https://github.com/martinellimarco/indexed_zstd/actions)
+![C++17](https://img.shields.io/badge/C++-17-blue.svg)
+[![AUR version](https://img.shields.io/aur/version/python-indexed-zstd)](https://aur.archlinux.org/packages/python-indexed-zstd/)
+
+# indexed_zstd
+
+This module provides an IndexedZstdFile class, which can be used to seek inside zstd files without having to decompress them first.
+
+It's shamelessy based on [indexed_bzip2](https://github.com/mxmlnkn/indexed_bzip2), which was refactored to support [zstd](https://github.com/facebook/zstd) instead of bzip2 using [libzstd-seek](https://github.com/martinellimarco/libzstd-seek).
+
+Kudos to the author for its work.
+
+Seeking inside a block is only emulated, so IndexedZstdFile will only speed up seeking when there are more than one block.
+
+To create multi-block archives you may use [t2sz](https://github.com/martinellimarco/t2sz/).
+
+
+# Usage
+
+## Example 1
+
+```python3
+from indexed_zstd import IndexedZstdFile
+
+file = IndexedZstdFile( "example.zst" )
+
+# You can now use it like a normal file
+file.seek( 123 )
+data = file.read( 100 )
+```
+
+
+%prep
+%autosetup -n indexed-zstd-1.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-indexed-zstd -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.0-1
+- Package Spec generated